summaryrefslogtreecommitdiff
path: root/tests
diff options
context:
space:
mode:
authorholger krekel <holger@merlinux.eu>2015-02-21 20:33:15 +0100
committerholger krekel <holger@merlinux.eu>2015-02-21 20:33:15 +0100
commit152f30d55d68973356083521523e47a2796d45c6 (patch)
tree9cf1df8d179feffef131d5db3a7ca2b0d5d0fb5d /tests
parenteca4bc058aae8beed720d71b0b4803fc05c26005 (diff)
parent192089fb9a72e4247489a9d841827d3d2ec8da1d (diff)
downloadtox-152f30d55d68973356083521523e47a2796d45c6.tar.gz
Merged in suor/tox/issue198 (pull request #129)
Diffstat (limited to 'tests')
-rw-r--r--tests/test_config.py12
-rw-r--r--tests/test_quickstart.py23
2 files changed, 27 insertions, 8 deletions
diff --git a/tests/test_config.py b/tests/test_config.py
index 229f035..f957771 100644
--- a/tests/test_config.py
+++ b/tests/test_config.py
@@ -960,6 +960,18 @@ class TestConfigTestEnv:
assert configs["py27"].setenv["X"] == "1"
assert "X" not in configs["py26"].setenv
+ @pytest.mark.issue191
+ def test_factor_use_not_checked(self, newconfig):
+ inisource="""
+ [tox]
+ envlist = py27-{a,b}
+
+ [testenv]
+ deps = b: test
+ """
+ configs = newconfig([], inisource).envconfigs
+ assert set(configs.keys()) == set(['py27-a', 'py27-b'])
+
@pytest.mark.issue198
def test_factors_groups_touch(self, newconfig):
inisource="""
diff --git a/tests/test_quickstart.py b/tests/test_quickstart.py
index df8a98f..5aaacc2 100644
--- a/tests/test_quickstart.py
+++ b/tests/test_quickstart.py
@@ -37,6 +37,7 @@ class TestToxQuickstartMain(object):
'Y', # py32
'Y', # py33
'Y', # py34
+ 'Y', # py35
'Y', # pypy
'N', # jython
'py.test', # command to run tests
@@ -54,7 +55,7 @@ class TestToxQuickstartMain(object):
# and then run "tox" from this directory.
[tox]
-envlist = py26, py27, py32, py33, py34, pypy
+envlist = py26, py27, py32, py33, py34, py35, pypy
[testenv]
commands = py.test
@@ -77,6 +78,7 @@ deps =
'Y', # py32
'Y', # py33
'Y', # py34
+ 'Y', # py35
'Y', # pypy
'N', # jython
'nosetests', # command to run tests
@@ -94,7 +96,7 @@ deps =
# and then run "tox" from this directory.
[tox]
-envlist = py26, py27, py32, py33, py34, pypy
+envlist = py26, py27, py32, py33, py34, py35, pypy
[testenv]
commands = nosetests
@@ -117,6 +119,7 @@ deps =
'Y', # py32
'Y', # py33
'Y', # py34
+ 'Y', # py35
'Y', # pypy
'N', # jython
'trial', # command to run tests
@@ -134,7 +137,7 @@ deps =
# and then run "tox" from this directory.
[tox]
-envlist = py26, py27, py32, py33, py34, pypy
+envlist = py26, py27, py32, py33, py34, py35, pypy
[testenv]
commands = trial
@@ -157,6 +160,7 @@ deps =
'Y', # py32
'Y', # py33
'Y', # py34
+ 'Y', # py35
'Y', # pypy
'N', # jython
'py.test', # command to run tests
@@ -173,7 +177,7 @@ deps =
# and then run "tox" from this directory.
[tox]
-envlist = py26, py27, py32, py33, py34, pypy
+envlist = py26, py27, py32, py33, py34, py35, pypy
[testenv]
commands = py.test
@@ -272,7 +276,7 @@ deps =
# and then run "tox" from this directory.
[tox]
-envlist = py26, py27, py32, py33, py34, pypy, jython
+envlist = py26, py27, py32, py33, py34, py35, pypy, jython
[testenv]
commands = py.test
@@ -295,6 +299,7 @@ deps =
'', # py32
'', # py33
'', # py34
+ '', # py35
'', # pypy
'', # jython
'', # command to run tests
@@ -312,7 +317,7 @@ deps =
# and then run "tox" from this directory.
[tox]
-envlist = py26, py27, py32, py33, py34, pypy, jython
+envlist = py26, py27, py32, py33, py34, py35, pypy, jython
[testenv]
commands = {envpython} setup.py test
@@ -339,6 +344,7 @@ deps =
'', # py32
'', # py33
'', # py34
+ '', # py35
'', # pypy
'', # jython
'', # command to run tests
@@ -357,7 +363,7 @@ deps =
# and then run "tox" from this directory.
[tox]
-envlist = py26, py27, py32, py33, py34, pypy, jython
+envlist = py26, py27, py32, py33, py34, py35, pypy, jython
[testenv]
commands = {envpython} setup.py test
@@ -459,6 +465,7 @@ deps =
'py32': True,
'py33': True,
'py34': True,
+ 'py35': True,
'pypy': True,
'commands': 'nosetests -v',
'deps': 'nose',
@@ -470,7 +477,7 @@ deps =
# and then run "tox" from this directory.
[tox]
-envlist = py27, py32, py33, py34, pypy
+envlist = py27, py32, py33, py34, py35, pypy
[testenv]
commands = nosetests -v