summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorholger krekel <holger@merlinux.eu>2013-08-06 07:47:01 +0200
committerholger krekel <holger@merlinux.eu>2013-08-06 07:47:01 +0200
commit51b05d96c8205f5e69a8f14d271932aadfdc2207 (patch)
treedb67eecd1f77e2629212ac57585c131d6e8daa97 /setup.py
parentafad7a309c3dc9ab947425da44caaeca584a4b46 (diff)
downloadtox-51b05d96c8205f5e69a8f14d271932aadfdc2207.tar.gz
introduce --reportjson=PATH option to write out test run information (version 1).
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py4
1 files changed, 3 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index bec9c6e..1f0636f 100644
--- a/setup.py
+++ b/setup.py
@@ -21,12 +21,14 @@ def main():
install_requires = ['virtualenv>=1.9.1', 'py>=1.4.15', ]
if version < (2, 7) or (3, 0) <= version <= (3, 1):
install_requires += ['argparse']
+ if version < (2,6):
+ install_requires += ["simplejson"]
setup(
name='tox',
description='virtualenv-based automation of test activities',
long_description=open("README.rst").read(),
url='http://tox.testrun.org/',
- version='1.5.1.dev2',
+ version='1.6.0.dev2',
license='http://opensource.org/licenses/MIT',
platforms=['unix', 'linux', 'osx', 'cygwin', 'win32'],
author='holger krekel',