summaryrefslogtreecommitdiff
path: root/doc
diff options
context:
space:
mode:
authorholger krekel <holger@merlinux.eu>2010-07-12 12:48:01 +0200
committerholger krekel <holger@merlinux.eu>2010-07-12 12:48:01 +0200
commit41f9f2d46d96fb3bc5a64d28623922539a521d2a (patch)
treec99a7bd2bab407d374959d5f72f33252fe1688dc /doc
parentdeb494bcd43ef5f7ff4967fc9a0ccf66b7ae1651 (diff)
downloadtox-41f9f2d46d96fb3bc5a64d28623922539a521d2a.tar.gz
introduce "-v" verbosity switch
bump version to 0.5 incorporate doc feedback from Ali
Diffstat (limited to 'doc')
-rw-r--r--doc/_templates/indexsidebar.html2
-rw-r--r--doc/announce/release-0.5.txt26
-rw-r--r--doc/conf.py2
-rw-r--r--doc/index.txt38
4 files changed, 66 insertions, 2 deletions
diff --git a/doc/_templates/indexsidebar.html b/doc/_templates/indexsidebar.html
index 12bf335..46ac476 100644
--- a/doc/_templates/indexsidebar.html
+++ b/doc/_templates/indexsidebar.html
@@ -7,7 +7,7 @@
released versions in the <a href="http://pypi.python.org/pypi/tox">Python
Package Index</a>.</p>
{% else %}
-<p>Current: <b>{{ version }}</b>
+<p>Current: <b><a href="{{pathto('announce/release-0.5')}}">{{ version }}</a></b>
[<a href="{{ pathto('changelog') }}">Changes</a>]</p>
<p>
<a href="http://pypi.python.org/pypi/tox">tox on PyPI</a>
diff --git a/doc/announce/release-0.5.txt b/doc/announce/release-0.5.txt
new file mode 100644
index 0000000..4b59d63
--- /dev/null
+++ b/doc/announce/release-0.5.txt
@@ -0,0 +1,26 @@
+tox 0.5: a generic virtualenv and test management tool for Python
+===========================================================================
+
+I have been talking about with various people in the last year and
+am happy to now announce the first release of ``tox``. It aims
+to automate tedious Python related test activities driven
+from a simple ``tox.ini`` file, including:
+
+* creation and management of different virtualenv environments
+* installing your package into each of them
+* running your test tool of choice (including e.g. running sphinx checks)
+* testing packages against each other without needing to upload to PyPI
+
+``tox`` runs well on Python2.4 up until Python3.1 and integrates
+well with Continous Integration servers Hudson. There are many
+real-life examples and a good chunk of docs. Read it up on
+
+ http://codespeak.net/tox
+
+and please report any issues. This is a fresh project and
+i'd like to drive further improvements from real world needs.
+
+best,
+
+holger krekel
+
diff --git a/doc/conf.py b/doc/conf.py
index c751241..bb06c7a 100644
--- a/doc/conf.py
+++ b/doc/conf.py
@@ -50,7 +50,7 @@ copyright = u'2010, holger krekel'
# The short X.Y version.
version = '0.5'
# The full version, including alpha/beta/rc tags.
-release = '0.5a2'
+release = '0.5'
# The language for content autogenerated by Sphinx. Refer to documentation
# for a list of supported languages.
diff --git a/doc/index.txt b/doc/index.txt
index 9371a90..455353c 100644
--- a/doc/index.txt
+++ b/doc/index.txt
@@ -8,6 +8,43 @@ vision: merge testing and deployment
deployment of Python software right from your console *or* CI
server, invoking your tools of choice.
+What is Tox?
+--------------------
+
+Tox as is a generic virtualenv_ management and test command line tool you can use for:
+
+* checking your package installs correctly with different Python versions and
+ interpreters
+
+* running your tests in each of the environments, configuring your test tool of choice
+
+* acting as a frontend to Continous Integration servers, greatly
+ reducing boilerplate and merging CI and shell-based testing.
+
+Basic example
+-----------------
+
+First, install ``tox`` with ``pip install tox`` or ``easy_install tox``.
+Then put basic information about your project and the test environments you
+want your project to run in into a ``tox.ini`` file residing
+right next to your ``setup.py`` file::
+
+ # content of: tox.ini , put in same dir as setup.py
+ [tox]
+ envlist = py26,py27
+ [testenv]
+ commands=py.test # or 'nosetests' or ...
+
+To sdist-package, install and test your project against Python2.6 and Python2.7, just type::
+
+ tox
+
+and watch things happening (you must have python2.6 and python2.7 installed in your
+environment otherwise you will see errors). When you run ``tox`` a second time
+you'll note that it runs much faster because it keeps track of virtualenv details
+and will not recreate or re-install dependencies. You also might want to
+checkout :doc:`examples` to get some more ideas.
+
Current features
-------------------
@@ -80,6 +117,7 @@ Notes and known limitations
support
changelog
links
+ announce/release-0.5
.. include:: links.txt