summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorholger krekel <holger@merlinux.eu>2015-06-03 13:29:33 +0200
committerholger krekel <holger@merlinux.eu>2015-06-03 13:29:33 +0200
commit926b053c783a8e5440dad28ac81b95e705c79da7 (patch)
tree0e7817324b9f8ed275bfe5c956126979306b3104
parentb1893f0b6cdfd87525a279dfe9a361ad837ec039 (diff)
downloadtox-926b053c783a8e5440dad28ac81b95e705c79da7.tar.gz
add SYSTEMDRIVE into default passenv on windows to allow pip6 to work.
Thanks Michael Krause.
-rw-r--r--CHANGELOG10
-rw-r--r--setup.py2
-rw-r--r--tests/test_config.py1
-rw-r--r--tox/__init__.py2
-rw-r--r--tox/config.py1
5 files changed, 11 insertions, 5 deletions
diff --git a/CHANGELOG b/CHANGELOG
index 003f386..3d782c1 100644
--- a/CHANGELOG
+++ b/CHANGELOG
@@ -1,8 +1,12 @@
-unreleased
+2.0.2
----------
-- tox now passes the LANG variable from the tox invocation environment to the
- test environment.
+- fix issue247: tox now passes the LANG variable from the tox invocation
+ environment to the test environment by default.
+
+- add SYSTEMDRIVE into default passenv on windows to allow pip6 to work.
+ Thanks Michael Krause.
+
2.0.1
-----------
diff --git a/setup.py b/setup.py
index 726d675..cad76e6 100644
--- a/setup.py
+++ b/setup.py
@@ -48,7 +48,7 @@ def main():
description='virtualenv-based automation of test activities',
long_description=open("README.rst").read(),
url='http://tox.testrun.org/',
- version='2.0.1',
+ version='2.0.2',
license='http://opensource.org/licenses/MIT',
platforms=['unix', 'linux', 'osx', 'cygwin', 'win32'],
author='holger krekel',
diff --git a/tests/test_config.py b/tests/test_config.py
index 1d91ace..4522f87 100644
--- a/tests/test_config.py
+++ b/tests/test_config.py
@@ -709,6 +709,7 @@ class TestConfigTestEnv:
envconfig = config.envconfigs['python']
if plat == "win32":
assert "PATHEXT" in envconfig.passenv
+ assert "SYSTEMDRIVE" in envconfig.passenv
assert "SYSTEMROOT" in envconfig.passenv
assert "TEMP" in envconfig.passenv
assert "TMP" in envconfig.passenv
diff --git a/tox/__init__.py b/tox/__init__.py
index 15acb39..2eccc2e 100644
--- a/tox/__init__.py
+++ b/tox/__init__.py
@@ -1,5 +1,5 @@
#
-__version__ = '2.0.1'
+__version__ = '2.0.2'
from .hookspecs import hookspec, hookimpl # noqa
diff --git a/tox/config.py b/tox/config.py
index a5be23c..0bc42be 100644
--- a/tox/config.py
+++ b/tox/config.py
@@ -394,6 +394,7 @@ def tox_addoption(parser):
# but this leads to very long paths when run with jenkins
# so we just pass it on by default for now.
if sys.platform == "win32":
+ passenv.add("SYSTEMDRIVE") # needed for pip6
passenv.add("SYSTEMROOT") # needed for python's crypto module
passenv.add("PATHEXT") # needed for discovering executables
passenv.add("TEMP")