summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorholger krekel <holger@merlinux.eu>2015-05-12 17:24:16 +0200
committerholger krekel <holger@merlinux.eu>2015-05-12 17:24:16 +0200
commit9e205ec9154673fcad042423999307270d2a7aa5 (patch)
tree322e040ceab721416a7085465370737ab53605ca
parentf79185294a8b36d73e0380220499ca641ea4450f (diff)
downloadtox-9e205ec9154673fcad042423999307270d2a7aa5.tar.gz
- fix TMP env variable and test on windows
- add release announcement - bump version to 2.0.0
-rw-r--r--doc/announce/release-2.0.txt57
-rw-r--r--doc/index.txt5
-rw-r--r--setup.py2
-rw-r--r--tests/test_config.py4
-rw-r--r--tox/__init__.py2
-rw-r--r--tox/config.py2
6 files changed, 69 insertions, 3 deletions
diff --git a/doc/announce/release-2.0.txt b/doc/announce/release-2.0.txt
index 9f87844..7943498 100644
--- a/doc/announce/release-2.0.txt
+++ b/doc/announce/release-2.0.txt
@@ -52,3 +52,60 @@ best,
Holger Krekel, merlinux GmbH
+2.0.0
+-----------
+
+- (new) introduce environment variable isolation:
+ tox now only passes the PATH variable from the tox
+ invocation environment to the test environment and on Windows
+ also ``SYSTEMROOT`` and ``PATHEXT``. If you need to pass through further
+ environment variables you can use the new ``passenv`` setting,
+ a space-separated list of environment variable names. Each name
+ can make use of fnmatch-style glob patterns. All environment
+ variables which exist in the tox-invocation environment will be copied
+ to the test environment.
+
+- (new) introduce a way to specify on which platform a testenvironment is to
+ execute: the new per-venv "platform" setting allows to specify
+ a regular expression which is matched against sys.platform.
+ If platform is set and doesn't match the platform spec in the test
+ environment the test environment is ignored, no setup or tests are attempted.
+
+- (new) add per-venv "ignore_errors" setting, which defaults to False.
+ If ``True``, a non-zero exit code from one command will be ignored and
+ further commands will be executed (which was the default behavior in tox <
+ 2.0). If ``False`` (the default), then a non-zero exit code from one command
+ will abort execution of commands for that environment.
+
+- show and store in json the version dependency information for each venv
+
+- remove the long-deprecated "distribute" option as it has no effect these days.
+
+- fix issue233: avoid hanging with tox-setuptools integration example. Thanks simonb.
+
+- fix issue120: allow substitution for the commands section. Thanks
+ Volodymyr Vitvitski.
+
+- fix issue235: fix AttributeError with --installpkg. Thanks
+ Volodymyr Vitvitski.
+
+- tox has now somewhat pep8 clean code, thanks to Volodymyr Vitvitski.
+
+- fix issue240: allow to specify empty argument list without it being
+ rewritten to ".". Thanks Daniel Hahler.
+
+- introduce experimental (not much documented yet) plugin system
+ based on pytest's externalized "pluggy" system.
+ See tox/hookspecs.py for the current hooks.
+
+- introduce parser.add_testenv_attribute() to register an ini-variable
+ for testenv sections. Can be used from plugins through the
+ tox_add_option hook.
+
+- rename internal files -- tox offers no external API except for the
+ experimental plugin hooks, use tox internals at your own risk.
+
+- DEPRECATE distshare in documentation
+
+
+
diff --git a/doc/index.txt b/doc/index.txt
index ed594cd..1a123fc 100644
--- a/doc/index.txt
+++ b/doc/index.txt
@@ -107,6 +107,8 @@ Current features
support
changelog
links
+ plugins
+ example/result
announce/release-0.5
announce/release-1.0
announce/release-1.1
@@ -114,6 +116,9 @@ Current features
announce/release-1.3
announce/release-1.4
announce/release-1.4.3
+ announce/release-1.8
+ announce/release-1.9
+ announce/release-2.0
.. include:: links.txt
diff --git a/setup.py b/setup.py
index 8edec31..960cbed 100644
--- a/setup.py
+++ b/setup.py
@@ -26,7 +26,7 @@ def main():
description='virtualenv-based automation of test activities',
long_description=open("README.rst").read(),
url='http://tox.testrun.org/',
- version='2.0.0.dev5',
+ version='2.0.0',
license='http://opensource.org/licenses/MIT',
platforms=['unix', 'linux', 'osx', 'cygwin', 'win32'],
author='holger krekel',
diff --git a/tests/test_config.py b/tests/test_config.py
index cce293e..97a3cf9 100644
--- a/tests/test_config.py
+++ b/tests/test_config.py
@@ -710,6 +710,10 @@ class TestConfigTestEnv:
if plat == "win32":
assert "PATHEXT" in envconfig.passenv
assert "SYSTEMROOT" in envconfig.passenv
+ assert "TEMP" in envconfig.passenv
+ assert "TMP" in envconfig.passenv
+ else:
+ assert "TMPDIR" in envconfig.passenv
assert "PATH" in envconfig.passenv
assert "A123A" in envconfig.passenv
assert "A123B" in envconfig.passenv
diff --git a/tox/__init__.py b/tox/__init__.py
index a23225b..6fd1335 100644
--- a/tox/__init__.py
+++ b/tox/__init__.py
@@ -1,5 +1,5 @@
#
-__version__ = '2.0.0.dev5'
+__version__ = '2.0.0'
from .hookspecs import hookspec, hookimpl # noqa
diff --git a/tox/config.py b/tox/config.py
index 8675286..d6dfcff 100644
--- a/tox/config.py
+++ b/tox/config.py
@@ -369,7 +369,7 @@ def tox_addoption(parser):
if sys.platform == "win32":
passenv.add("SYSTEMROOT") # needed for python's crypto module
passenv.add("PATHEXT") # needed for discovering executables
- passenv.add("TEMPDIR")
+ passenv.add("TEMP")
passenv.add("TMP")
else:
passenv.add("TMPDIR")