summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorholger krekel <holger@merlinux.eu>2013-10-24 09:43:56 +0200
committerholger krekel <holger@merlinux.eu>2013-10-24 09:43:56 +0200
commitd0dab5fd7caaf90e25d85def4d7e5cf47265bef4 (patch)
treec4e3bcd2a4acc4e555353653675a361864b44725
parent838d35ad0b707ebe5dc6a3ee7c20be737501a6ed (diff)
downloadtox-d0dab5fd7caaf90e25d85def4d7e5cf47265bef4.tar.gz
fix issue126: depend on virtualenv>=1.10.1 so that we can rely
(hopefully) on a pip version which supports --pre. (tox by default uses to --pre). Note that tox also vendors an older virtualenv for supporting python2.5 -- although the latter will be dropped at some point.
-rwxr-xr-xCHANGELOG9
-rw-r--r--setup.py2
2 files changed, 8 insertions, 3 deletions
diff --git a/CHANGELOG b/CHANGELOG
index 14889c2..7ae0301 100755
--- a/CHANGELOG
+++ b/CHANGELOG
@@ -1,9 +1,14 @@
1.6.2.dev
---------
+- fix issue126: depend on virtualenv>=1.10.1 so that we can rely
+ (hopefully) on a pip version which supports --pre. (tox by default
+ uses to --pre). Note that tox also vendors an older virtualenv
+ for supporting python2.5 -- although the latter will be dropped at some point.
+
- fix issue130: you can now set install_command=easy_install {opts} {packages}
- and expect it to run without the need to recreate. Thanks jenisys for
- precise reporting.
+ and expect it to work for repeated tox runs (previously it only worked
+ when always recreating). Thanks jenisys for precise reporting.
- fix issue129: tox now uses Popen(..., universal_newlines=True) to force
creation of unicode stdout/stderr streams. fixes a problem on specific
diff --git a/setup.py b/setup.py
index 6d18cf0..193cbd4 100644
--- a/setup.py
+++ b/setup.py
@@ -18,7 +18,7 @@ class Tox(TestCommand):
def main():
version = sys.version_info[:2]
- install_requires = ['virtualenv>=1.9.1', 'py>=1.4.15', ]
+ install_requires = ['virtualenv>=1.10.1', 'py>=1.4.17', ]
if version < (2, 7) or (3, 0) <= version <= (3, 1):
install_requires += ['argparse']
if version < (2,6):