summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorholger krekel <holger@merlinux.eu>2014-07-20 11:27:59 +0200
committerholger krekel <holger@merlinux.eu>2014-07-20 11:27:59 +0200
commit2a1b4b9ead07c0d2dde61640fb47012cbc236edd (patch)
tree8b5d4bf462200075fa7c3f1fe6acb45fbc0e57ec
parentd95962973c14568343cafb62be4279d4312d5975 (diff)
parent59bd2df040b608a02d3708c2c461c1678274452f (diff)
downloadtox-2a1b4b9ead07c0d2dde61640fb47012cbc236edd.tar.gz
merge Alexander's "multi-dimensional" PR.
-rw-r--r--CHANGELOG9
-rw-r--r--CONTRIBUTORS1
-rw-r--r--doc/conf.py2
-rw-r--r--setup.py2
-rw-r--r--tests/test_config.py8
-rw-r--r--tests/test_venv.py2
-rw-r--r--tox/__init__.py2
-rw-r--r--tox/_config.py3
8 files changed, 19 insertions, 10 deletions
diff --git a/CHANGELOG b/CHANGELOG
index b4e7155..9d991c7 100644
--- a/CHANGELOG
+++ b/CHANGELOG
@@ -1,4 +1,11 @@
-development
+1.8.0.dev1
+-----------
+
+- new multi-dimensional configuration support. Many thanks to
+ Alexander Schepanovski for the complete PR with docs.
+
+
+1.7.2
-----------
- fix issue150: parse {posargs} more like we used to do it pre 1.7.0.
diff --git a/CONTRIBUTORS b/CONTRIBUTORS
index d10950b..ef8576d 100644
--- a/CONTRIBUTORS
+++ b/CONTRIBUTORS
@@ -3,6 +3,7 @@ contributions:
Krisztian Fekete
Marc Abramowitz
+Aleaxner Schepanovski
Sridhar Ratnakumar
Barry Warsaw
Chris Rose
diff --git a/doc/conf.py b/doc/conf.py
index 76dc4c3..ceb3397 100644
--- a/doc/conf.py
+++ b/doc/conf.py
@@ -48,7 +48,7 @@ copyright = u'2013, holger krekel and others'
# built documents.
#
# The short X.Y version.
-release = version = "1.7.1"
+release = version = "1.7.2"
# The full version, including alpha/beta/rc tags.
# The language for content autogenerated by Sphinx. Refer to documentation
diff --git a/setup.py b/setup.py
index fe22de3..8e2f8f0 100644
--- a/setup.py
+++ b/setup.py
@@ -28,7 +28,7 @@ def main():
description='virtualenv-based automation of test activities',
long_description=open("README.rst").read(),
url='http://tox.testrun.org/',
- version='1.7.2.dev1',
+ version='1.7.2',
license='http://opensource.org/licenses/MIT',
platforms=['unix', 'linux', 'osx', 'cygwin', 'win32'],
author='holger krekel',
diff --git a/tests/test_config.py b/tests/test_config.py
index d7a7451..28afa6c 100644
--- a/tests/test_config.py
+++ b/tests/test_config.py
@@ -554,7 +554,7 @@ class TestConfigTestEnv:
envconfig = config.envconfigs['python']
assert envconfig.envpython == envconfig.envbindir.join("python")
- @pytest.mark.parametrize("bp", ["jython", "pypy"])
+ @pytest.mark.parametrize("bp", ["jython", "pypy", "pypy3"])
def test_envbindir_jython(self, tmpdir, newconfig, bp):
config = newconfig("""
[testenv]
@@ -948,7 +948,7 @@ class TestGlobalOptions:
assert str(env.basepython) == sys.executable
def test_default_environments(self, tmpdir, newconfig, monkeypatch):
- envs = "py26,py27,py31,py32,py33,jython,pypy"
+ envs = "py26,py27,py31,py32,py33,py34,jython,pypy,pypy3"
inisource = """
[tox]
envlist = %s
@@ -960,8 +960,8 @@ class TestGlobalOptions:
env = config.envconfigs[name]
if name == "jython":
assert env.basepython == "jython"
- elif name == "pypy":
- assert env.basepython == "pypy"
+ elif name.startswith("pypy"):
+ assert env.basepython == name
else:
assert name.startswith("py")
bp = "python%s.%s" %(name[2], name[3])
diff --git a/tests/test_venv.py b/tests/test_venv.py
index dbfec41..6482e09 100644
--- a/tests/test_venv.py
+++ b/tests/test_venv.py
@@ -584,7 +584,7 @@ def test_command_relative_issue26(newmocksession, tmpdir, monkeypatch):
mocksession.report.not_expect("warning", "*test command found but not*")
monkeypatch.setenv("PATH", str(tmpdir))
x4 = venv.getcommandpath("x", cwd=tmpdir)
- assert x4.endswith('/x')
+ assert x4.endswith(os.sep + 'x')
mocksession.report.expect("warning", "*test command found but not*")
def test_sethome_only_on_option(newmocksession, monkeypatch):
diff --git a/tox/__init__.py b/tox/__init__.py
index 537c37d..530f3c4 100644
--- a/tox/__init__.py
+++ b/tox/__init__.py
@@ -1,5 +1,5 @@
#
-__version__ = '1.7.2.dev1'
+__version__ = '1.7.2'
class exception:
class Error(Exception):
diff --git a/tox/_config.py b/tox/_config.py
index 3a12d93..6e8e706 100644
--- a/tox/_config.py
+++ b/tox/_config.py
@@ -16,7 +16,8 @@ import tox
iswin32 = sys.platform == "win32"
-default_factors = {'jython': 'jython', 'pypy': 'pypy', 'py': sys.executable}
+default_factors = {'jython': 'jython', 'pypy': 'pypy', 'pypy3': 'pypy3',
+ 'py': sys.executable}
for version in '24,25,26,27,30,31,32,33,34'.split(','):
default_factors['py' + version] = 'python%s.%s' % tuple(version)