summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorholger krekel <holger@merlinux.eu>2015-04-21 16:39:13 +0200
committerholger krekel <holger@merlinux.eu>2015-04-21 16:39:13 +0200
commit8b4f65e405e9881cfcaf3014b1abbdc832c6da7b (patch)
treefe3382a6aba374ec638722f8c0a7222cee1c02f4
parente376e97c966e2f0bcd1286d3b928b2d8cab45768 (diff)
downloadtox-8b4f65e405e9881cfcaf3014b1abbdc832c6da7b.tar.gz
fix issue233: avoid hanging with tox-setuptools integration example. Thanks simonb.
-rw-r--r--CHANGELOG2
-rw-r--r--doc/example/basic.txt5
2 files changed, 6 insertions, 1 deletions
diff --git a/CHANGELOG b/CHANGELOG
index dc8ec7e..b1e8d49 100644
--- a/CHANGELOG
+++ b/CHANGELOG
@@ -19,6 +19,8 @@
- remove the long-deprecated "distribute" option as it has no effect these days.
+- fix issue233: avoid hanging with tox-setuptools integration example. Thanks simonb.
+
1.9.2
-----------
diff --git a/doc/example/basic.txt b/doc/example/basic.txt
index f4df233..d0ad004 100644
--- a/doc/example/basic.txt
+++ b/doc/example/basic.txt
@@ -254,7 +254,10 @@ a test run when ``python setup.py test`` is issued::
#import here, cause outside the eggs aren't loaded
import tox
import shlex
- errno = tox.cmdline(args=shlex.split(self.tox_args))
+ args = self.tox_args
+ if args:
+ args = shlex.split(self.tox_args)
+ errno = tox.cmdline(args=args)
sys.exit(errno)
setup(