summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMark Hirota <mhirota@impinj.com>2015-02-11 11:11:54 -0800
committerMark Hirota <mhirota@impinj.com>2015-02-11 11:11:54 -0800
commitbbb20864027197f81b901850cac6787e47c08803 (patch)
tree0ab00ccead42cb2c6b0d3dcab89fd6da0c9fe25c
parentaa7c071cfde63f9d1da4c0409d77305f970e6924 (diff)
downloadtox-bbb20864027197f81b901850cac6787e47c08803.tar.gz
Update doc files for issue #124 fix
-rw-r--r--doc/config.txt2
-rw-r--r--doc/example/basic.txt16
2 files changed, 18 insertions, 0 deletions
diff --git a/doc/config.txt b/doc/config.txt
index 6ffd02b..b2d9024 100644
--- a/doc/config.txt
+++ b/doc/config.txt
@@ -86,6 +86,8 @@ Complete list of settings that you can put into ``testenv*`` sections:
will be appended (and may contain another ``\`` character ...).
For eventually performing a call to ``subprocess.Popen(args, ...)``
``args`` are determined by splitting the whole command by whitespace.
+ Similar to ``make`` recipe lines, any command with a leading ``-``
+ will ignore the exit code.
.. confval:: install_command=ARGV
diff --git a/doc/example/basic.txt b/doc/example/basic.txt
index 49baeee..916990e 100644
--- a/doc/example/basic.txt
+++ b/doc/example/basic.txt
@@ -244,3 +244,19 @@ using the ``--tox-args`` or ``-a`` command-line options. For example::
python setup.py test -a "-epy27"
is equivalent to running ``tox -epy27``.
+
+Ignoring a command exit code
+----------------------------
+
+In some cases, you may want to ignore a command exit code. For example::
+
+ [testenv:py27]
+ commands = coverage erase
+ {envbindir}/python setup.py develop
+ coverage run -p setup.py test
+ coverage combine
+ - coverage html
+ {envbindir}/flake8 loads
+
+By using the ``-`` prefix, similar to a ``make`` recipe line, you can ignore
+the exit code for that command.