summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorholger krekel <holger@merlinux.eu>2015-03-11 20:31:47 +0100
committerholger krekel <holger@merlinux.eu>2015-03-11 20:31:47 +0100
commit779497bf8545777dc7b8f3dfa8f4c4e9bfc2c7b7 (patch)
tree5e4e7c7e6ebebe8b9456997b31c90be36d67f75b
parent189c9d4d9344db7fee7db9f00a59bfcde358dfad (diff)
downloadtox-779497bf8545777dc7b8f3dfa8f4c4e9bfc2c7b7.tar.gz
fix issue227: use "-m virtualenv" instead of "-m virtualenv" to make
it work with pyrun.
-rw-r--r--CHANGELOG3
-rw-r--r--setup.py2
-rw-r--r--tox/__init__.py2
-rw-r--r--tox/_venv.py2
4 files changed, 6 insertions, 3 deletions
diff --git a/CHANGELOG b/CHANGELOG
index 0b6915f..66350c7 100644
--- a/CHANGELOG
+++ b/CHANGELOG
@@ -4,6 +4,9 @@ DEV
- allow --force-deps to override dependencies in "-r" requirements
files. Thanks Sontek for the PR.
+- fix issue227: use "-m virtualenv" instead of "-m virtualenv" to make
+ it work with pyrun.
+
1.9.0
-----------
diff --git a/setup.py b/setup.py
index 7373f85..b67fec3 100644
--- a/setup.py
+++ b/setup.py
@@ -26,7 +26,7 @@ def main():
description='virtualenv-based automation of test activities',
long_description=open("README.rst").read(),
url='http://tox.testrun.org/',
- version='1.9.1.dev1',
+ version='1.9.1.dev2',
license='http://opensource.org/licenses/MIT',
platforms=['unix', 'linux', 'osx', 'cygwin', 'win32'],
author='holger krekel',
diff --git a/tox/__init__.py b/tox/__init__.py
index 331f2cb..912981c 100644
--- a/tox/__init__.py
+++ b/tox/__init__.py
@@ -1,5 +1,5 @@
#
-__version__ = '1.9.1.dev1'
+__version__ = '1.9.1.dev2'
class exception:
class Error(Exception):
diff --git a/tox/_venv.py b/tox/_venv.py
index 6bcb88a..65eb73b 100644
--- a/tox/_venv.py
+++ b/tox/_venv.py
@@ -178,7 +178,7 @@ class VirtualEnv(object):
action = self.session.newaction(self, "create")
config_interpreter = self.getsupportedinterpreter()
- args = [sys.executable, '-mvirtualenv']
+ args = [sys.executable, '-m', 'virtualenv']
if self.envconfig.distribute:
args.append("--distribute")
else: