summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorholger krekel <holger@merlinux.eu>2014-01-23 08:48:15 +0100
committerholger krekel <holger@merlinux.eu>2014-01-23 08:48:15 +0100
commitb33b1f5d79634e4b214d3a8c7ca110cd4b77349b (patch)
tree03d05d95a04cd63c275478f5989d3c5f3441ca57
parent04cdb6f55ef53f1f4196969d47f6216b03661d74 (diff)
downloadtox-b33b1f5d79634e4b214d3a8c7ca110cd4b77349b.tar.gz
fix issue140: depend on virtualenv>=1.11.1
-rwxr-xr-xCHANGELOG10
-rw-r--r--setup.py4
-rw-r--r--tox.ini5
-rw-r--r--tox/__init__.py2
-rw-r--r--tox/_venv.py2
5 files changed, 16 insertions, 7 deletions
diff --git a/CHANGELOG b/CHANGELOG
index 284a310..5964fe1 100755
--- a/CHANGELOG
+++ b/CHANGELOG
@@ -1,6 +1,11 @@
-1.6.2.dev
+1.7.0.dev
---------
+- don't lookup "pip-script" anymore but rather just "pip" on windows
+ as this is a pip implementation detail and changed with pip-1.5.
+ It might mean that tox-1.7 is not able to install a different pip
+ version into a virtualenv anymore.
+
- drop Python2.5 compatibility because it became too hard due
to the setuptools-2.0 dropping support. tox now has no
support for creating python2.5 based environments anymore
@@ -22,10 +27,11 @@
to allow installation of tox
via easy_install/eggs. Thanks Jenisys.
-- fix issue126: depend on virtualenv>=1.10.1 so that we can rely
+- fix issue126: depend on virtualenv>=1.11.1 so that we can rely
(hopefully) on a pip version which supports --pre. (tox by default
uses to --pre). also merged in PR84 so that we now call "virtualenv"
directly instead of looking up interpreters. Thanks Ionel Maries Cristian.
+ This also fixes issue140.
- fix issue130: you can now set install_command=easy_install {opts} {packages}
and expect it to work for repeated tox runs (previously it only worked
diff --git a/setup.py b/setup.py
index ecce413..b5f43da 100644
--- a/setup.py
+++ b/setup.py
@@ -18,7 +18,7 @@ class Tox(TestCommand):
def main():
version = sys.version_info[:2]
- install_requires = ['virtualenv>=1.10.1', 'py>=1.4.17', ]
+ install_requires = ['virtualenv>=1.11.1', 'py>=1.4.17', ]
if version < (2, 7) or (3, 0) <= version <= (3, 1):
install_requires += ['argparse']
if version < (2,6):
@@ -28,7 +28,7 @@ def main():
description='virtualenv-based automation of test activities',
long_description=open("README.rst").read(),
url='http://tox.testrun.org/',
- version='1.7.0.dev1',
+ version='1.7.0.dev2',
license='http://opensource.org/licenses/MIT',
platforms=['unix', 'linux', 'osx', 'cygwin', 'win32'],
author='holger krekel',
diff --git a/tox.ini b/tox.ini
index f2fc791..58858d3 100644
--- a/tox.ini
+++ b/tox.ini
@@ -8,6 +8,11 @@ commands=echo {posargs}
commands=py.test --junitxml={envlogdir}/junit-{envname}.xml {posargs}
deps=pytest>=2.3.5
+[testenv:x]
+setenv=
+ HELLO=echo hello world
+commands={env:HELLO}
+
[testenv:docs]
basepython=python
changedir=doc
diff --git a/tox/__init__.py b/tox/__init__.py
index 0c62362..b0e2267 100644
--- a/tox/__init__.py
+++ b/tox/__init__.py
@@ -1,5 +1,5 @@
#
-__version__ = '1.7.0.dev1'
+__version__ = '1.7.0.dev2'
class exception:
class Error(Exception):
diff --git a/tox/_venv.py b/tox/_venv.py
index 3ad0817..f8282d8 100644
--- a/tox/_venv.py
+++ b/tox/_venv.py
@@ -268,8 +268,6 @@ class VirtualEnv(object):
extraenv=None):
argv = self.envconfig.install_command[:]
# use pip-script on win32 to avoid the executable locking
- if argv[0] == "pip" and sys.platform == "win32":
- argv[0] = "pip-script.py"
i = argv.index('{packages}')
argv[i:i+1] = packages
if '{opts}' in argv: