summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorholger krekel <holger@merlinux.eu>2013-02-19 14:43:50 +0100
committerholger krekel <holger@merlinux.eu>2013-02-19 14:43:50 +0100
commit30a7b7000176bbbb5766bb2a4ca7f3943b157a5d (patch)
tree8dfb85653c8430badd27dba0f519701635788f44
parent1ab5b3f197e42e86d29a7bad6324c675b448684a (diff)
downloadtox-30a7b7000176bbbb5766bb2a4ca7f3943b157a5d.tar.gz
add -l to changelog, lukasz to contributors and some refinements
-rwxr-xr-xCHANGELOG3
-rw-r--r--CONTRIBUTORS2
-rw-r--r--setup.py4
-rw-r--r--tests/test_config.py18
-rw-r--r--tox/_cmdline.py4
-rw-r--r--tox/_config.py4
6 files changed, 21 insertions, 14 deletions
diff --git a/CHANGELOG b/CHANGELOG
index 621c149..5e9a378 100755
--- a/CHANGELOG
+++ b/CHANGELOG
@@ -1,6 +1,9 @@
1.4.3.dev
-----------------
+- introduce -l|--listenv option to list configured environments
+ (thanks Lukasz Balcerzak)
+
- fix downloadcache determination to work according to docs: Only
make pip use a download cache if PIP_DOWNLOAD_CACHE or a
downloadcache=PATH testenv setting is present. (The ENV setting
diff --git a/CONTRIBUTORS b/CONTRIBUTORS
index e8133fc..70c5f7d 100644
--- a/CONTRIBUTORS
+++ b/CONTRIBUTORS
@@ -5,3 +5,5 @@ Marc Abramowitz
Sridhar Ratnakumar
Chris Rose
Jannis Leidl
+Ronny Pfannschmidt
+Lukasz Balcerzak
diff --git a/setup.py b/setup.py
index bca2edf..9c408fd 100644
--- a/setup.py
+++ b/setup.py
@@ -41,7 +41,7 @@ class Tox(TestCommand):
def main():
version = sys.version_info[:2]
- install_requires = ['virtualenv==1.8.4', 'py>=1.4.9', ]
+ install_requires = ['virtualenv>=1.8.4', 'py>=1.4.9', ]
if version < (2, 7) or (3, 0) <= version <= (3, 1):
install_requires += ['argparse']
setup(
@@ -77,4 +77,4 @@ def main():
)
if __name__ == '__main__':
- main() \ No newline at end of file
+ main()
diff --git a/tests/test_config.py b/tests/test_config.py
index 92906b5..40d6941 100644
--- a/tests/test_config.py
+++ b/tests/test_config.py
@@ -786,19 +786,21 @@ class TestCmdInvocation:
[tox]
envlist=py26,py27,py33,pypy,docs
+ [testenv:notincluded]
+ changedir = whatever
+
[testenv:docs]
changedir = docs
''',
})
result = cmd.run("tox", "-l")
- stdout = result.stdout.str()
- assert stdout.splitlines() == [
- ' * py26',
- ' * py27',
- ' * py33',
- ' * pypy',
- ' * docs',
- ]
+ result.stdout.fnmatch_lines("""
+ *py26*
+ *py27*
+ *py33*
+ *pypy*
+ *docs*
+ """)
@py.test.mark.xfail("sys.version_info < (2,6)",
reason="virtualenv3 cannot be imported")
diff --git a/tox/_cmdline.py b/tox/_cmdline.py
index e9bc454..ca19212 100644
--- a/tox/_cmdline.py
+++ b/tox/_cmdline.py
@@ -271,7 +271,7 @@ class Session:
raise SystemExit(1)
if self.config.option.showconfig:
self.showconfig()
- elif self.config.option.list_envs:
+ elif self.config.option.listenvs:
self.showenvs()
else:
return self.subcommand_test()
@@ -419,7 +419,7 @@ class Session:
def showenvs(self):
for env in self.config.envlist:
- self.report.line(" * %s" % env)
+ self.report.line("%s" % env)
def info_versions(self):
versions = ['tox-%s' % tox.__version__]
diff --git a/tox/_config.py b/tox/_config.py
index 4a75171..9d97aed 100644
--- a/tox/_config.py
+++ b/tox/_config.py
@@ -77,6 +77,8 @@ def prepare_parse(pkgname):
help="increase verbosity of reporting output.")
parser.add_argument("--showconfig", action="store_true", dest="showconfig",
help="show configuration information. ")
+ parser.add_argument("-l", "--listenvs", action="store_true",
+ dest="listenvs", help="show list of test environments")
parser.add_argument("-c", action="store", default="tox.ini",
dest="configfile",
help="use the specified config file name.")
@@ -98,8 +100,6 @@ def prepare_parse(pkgname):
help="force recreation of virtual environments")
parser.add_argument("args", nargs="*",
help="additional arguments available to command positional substition")
- parser.add_argument("-l", "--list", action="store_true", dest="list_envs",
- help="show default envlist")
return parser
class Config: