summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorholger krekel <holger@merlinux.eu>2015-12-07 12:49:18 +0100
committerholger krekel <holger@merlinux.eu>2015-12-07 12:49:18 +0100
commit8edad9ed7263483a98171467efee67efbb52b259 (patch)
treeeac052396723131ff82f3d219560dea657797a99
parent905f2c06e9b37d307562ce3cfbffb51018829a7c (diff)
downloadtox-8edad9ed7263483a98171467efee67efbb52b259.tar.gz
add py35 to default test envs and automize versions generated in docissue285
-rw-r--r--doc/Makefile4
-rwxr-xr-xdoc/_getdoctarget.py16
-rw-r--r--doc/conf.py10
-rw-r--r--tox.ini2
4 files changed, 28 insertions, 4 deletions
diff --git a/doc/Makefile b/doc/Makefile
index 4ffb98b..aae1962 100644
--- a/doc/Makefile
+++ b/doc/Makefile
@@ -12,6 +12,8 @@ PAPEROPT_a4 = -D latex_paper_size=a4
PAPEROPT_letter = -D latex_paper_size=letter
ALLSPHINXOPTS = -d $(BUILDDIR)/doctrees $(PAPEROPT_$(PAPER)) $(SPHINXOPTS) .
+SITETARGET=$(shell ./_getdoctarget.py)
+
.PHONY: help clean html dirhtml singlehtml pickle json htmlhelp qthelp devhelp epub latex latexpdf text man changes linkcheck doctest
help:
@@ -36,8 +38,10 @@ help:
clean:
-rm -rf $(BUILDDIR)/*
+
install: clean html
@rsync -avz $(BUILDDIR)/html/ testrun.org:/www/testrun.org/tox/latest
+ @rsync -avz $(BUILDDIR)/html/ testrun.org:/www/testrun.org/tox/$(SITETARGET)
#dev
#latexpdf
#@scp $(BUILDDIR)/latex/*.pdf testrun.org:www-tox/latest
diff --git a/doc/_getdoctarget.py b/doc/_getdoctarget.py
new file mode 100755
index 0000000..1199221
--- /dev/null
+++ b/doc/_getdoctarget.py
@@ -0,0 +1,16 @@
+#!/usr/bin/env python
+
+import py
+
+def get_version_string():
+ fn = py.path.local(__file__).join("..", "..",
+ "tox", "__init__.py")
+ for line in fn.readlines():
+ if "version" in line and not line.strip().startswith('#'):
+ return eval(line.split("=")[-1])
+
+def get_minor_version_string():
+ return ".".join(get_version_string().split(".")[:2])
+
+if __name__ == "__main__":
+ print (get_minor_version_string())
diff --git a/doc/conf.py b/doc/conf.py
index 79857d7..6094f60 100644
--- a/doc/conf.py
+++ b/doc/conf.py
@@ -13,6 +13,13 @@
import sys, os
+# The short X.Y version.
+sys.path.insert(0, os.path.dirname(__file__))
+import _getdoctarget
+
+version = _getdoctarget.get_minor_version_string()
+release = _getdoctarget.get_version_string()
+
# If extensions (or modules to document with autodoc) are in another directory,
# add these directories to sys.path here. If the directory is relative to the
# documentation root, use os.path.abspath to make it absolute, like shown here.
@@ -47,9 +54,6 @@ copyright = u'2015, holger krekel and others'
# |version| and |release|, also used in various other places throughout the
# built documents.
#
-# The short X.Y version.
-release = "2.2"
-version = "2.2.0"
# The full version, including alpha/beta/rc tags.
# The language for content autogenerated by Sphinx. Refer to documentation
diff --git a/tox.ini b/tox.ini
index e79b882..17efc83 100644
--- a/tox.ini
+++ b/tox.ini
@@ -1,5 +1,5 @@
[tox]
-envlist=py27,py26,py34,py33,pypy,flakes,py26-bare
+envlist=py27,py26,py34,py33,py35,pypy,flakes,py26-bare
[testenv:X]
commands=echo {posargs}