summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorholger krekel <holger@merlinux.eu>2014-01-29 14:03:13 +0100
committerholger krekel <holger@merlinux.eu>2014-01-29 14:03:13 +0100
commit6e0c35f06044848b7d2015c36b77c25ae2576025 (patch)
treec04a86c1ae883b705562c558b9a207d7b37b4949
parentb33b1f5d79634e4b214d3a8c7ca110cd4b77349b (diff)
downloadtox-6e0c35f06044848b7d2015c36b77c25ae2576025.tar.gz
try to go for 1.7.01.7.0
-rwxr-xr-xCHANGELOG4
-rw-r--r--README.rst2
-rw-r--r--setup.py4
-rw-r--r--tox.ini5
-rw-r--r--tox/__init__.py2
5 files changed, 6 insertions, 11 deletions
diff --git a/CHANGELOG b/CHANGELOG
index 5964fe1..2fe431f 100755
--- a/CHANGELOG
+++ b/CHANGELOG
@@ -1,4 +1,4 @@
-1.7.0.dev
+1.7.0
---------
- don't lookup "pip-script" anymore but rather just "pip" on windows
@@ -27,7 +27,7 @@
to allow installation of tox
via easy_install/eggs. Thanks Jenisys.
-- fix issue126: depend on virtualenv>=1.11.1 so that we can rely
+- fix issue126: depend on virtualenv>=1.11.2 so that we can rely
(hopefully) on a pip version which supports --pre. (tox by default
uses to --pre). also merged in PR84 so that we now call "virtualenv"
directly instead of looking up interpreters. Thanks Ionel Maries Cristian.
diff --git a/README.rst b/README.rst
index 0fb6c68..2beeadd 100644
--- a/README.rst
+++ b/README.rst
@@ -21,5 +21,5 @@ For more information and the repository please checkout:
have fun,
-holger krekel, May 2013
+holger krekel, January 2014
diff --git a/setup.py b/setup.py
index b5f43da..5a61aa1 100644
--- a/setup.py
+++ b/setup.py
@@ -18,7 +18,7 @@ class Tox(TestCommand):
def main():
version = sys.version_info[:2]
- install_requires = ['virtualenv>=1.11.1', 'py>=1.4.17', ]
+ install_requires = ['virtualenv>=1.11.2', 'py>=1.4.17', ]
if version < (2, 7) or (3, 0) <= version <= (3, 1):
install_requires += ['argparse']
if version < (2,6):
@@ -28,7 +28,7 @@ def main():
description='virtualenv-based automation of test activities',
long_description=open("README.rst").read(),
url='http://tox.testrun.org/',
- version='1.7.0.dev2',
+ version='1.7.0',
license='http://opensource.org/licenses/MIT',
platforms=['unix', 'linux', 'osx', 'cygwin', 'win32'],
author='holger krekel',
diff --git a/tox.ini b/tox.ini
index 58858d3..f2fc791 100644
--- a/tox.ini
+++ b/tox.ini
@@ -8,11 +8,6 @@ commands=echo {posargs}
commands=py.test --junitxml={envlogdir}/junit-{envname}.xml {posargs}
deps=pytest>=2.3.5
-[testenv:x]
-setenv=
- HELLO=echo hello world
-commands={env:HELLO}
-
[testenv:docs]
basepython=python
changedir=doc
diff --git a/tox/__init__.py b/tox/__init__.py
index b0e2267..5ff0e85 100644
--- a/tox/__init__.py
+++ b/tox/__init__.py
@@ -1,5 +1,5 @@
#
-__version__ = '1.7.0.dev2'
+__version__ = '1.7.0'
class exception:
class Error(Exception):