summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorholger krekel <holger@merlinux.eu>2013-07-09 13:40:04 +0200
committerholger krekel <holger@merlinux.eu>2013-07-09 13:40:04 +0200
commit08c2aaac036791e2be8b0e634d722ba0971b5216 (patch)
tree233bb156d64ae7a8f5831df515f20b564ae7993d
parent15b75acb0f8dfae1a03d0efa77a6c910d2c1be57 (diff)
downloadtox-08c2aaac036791e2be8b0e634d722ba0971b5216.tar.gz
always unset PYTHONDONTWRITEBYTE because newer setuptools doesn't like it
-rwxr-xr-xCHANGELOG5
-rw-r--r--doc/index.txt3
-rw-r--r--setup.py2
-rw-r--r--tox/__init__.py2
-rw-r--r--tox/_venv.py9
-rw-r--r--toxbootstrap.py2
6 files changed, 15 insertions, 8 deletions
diff --git a/CHANGELOG b/CHANGELOG
index 3cce0bf..078e231 100755
--- a/CHANGELOG
+++ b/CHANGELOG
@@ -1,3 +1,8 @@
+1.5.1.dev
+-----------------
+
+- always unset PYTHONDONTWRITEBYTE because newer setuptools doesn't like it
+
1.5.0
-----------------
diff --git a/doc/index.txt b/doc/index.txt
index 20d65d4..1838b3b 100644
--- a/doc/index.txt
+++ b/doc/index.txt
@@ -1,7 +1,8 @@
Welcome to the tox automation project
===============================================
-.. note:: Upcoming: `professional testing with pytest and tox <http://www.python-academy.com/courses/specialtopics/python_course_testing.html>`_ , 24th-26th June 2013, Leipzig.
+..
+ Upcoming: `professional testing with pytest and tox <http://www.python-academy.com/courses/specialtopics/python_course_testing.html>`_ , 24th-26th June 2013, Leipzig.
vision: standardize testing in Python
---------------------------------------------
diff --git a/setup.py b/setup.py
index 095275f..c7cb592 100644
--- a/setup.py
+++ b/setup.py
@@ -26,7 +26,7 @@ def main():
description='virtualenv-based automation of test activities',
long_description=open("README.rst").read(),
url='http://tox.testrun.org/',
- version='1.5.0',
+ version='1.5.1.dev1',
license='http://opensource.org/licenses/MIT',
platforms=['unix', 'linux', 'osx', 'cygwin', 'win32'],
author='holger krekel',
diff --git a/tox/__init__.py b/tox/__init__.py
index 02f0744..ed82f37 100644
--- a/tox/__init__.py
+++ b/tox/__init__.py
@@ -1,5 +1,5 @@
#
-__version__ = '1.5.0'
+__version__ = '1.5.1.dev1'
class exception:
class Error(Exception):
diff --git a/tox/_venv.py b/tox/_venv.py
index 7d9d347..f23557a 100644
--- a/tox/_venv.py
+++ b/tox/_venv.py
@@ -301,10 +301,11 @@ class VirtualEnv(object):
def _pcall(self, args, venv=True, cwd=None, extraenv={},
action=None, redirect=True):
- try:
- del os.environ['VIRTUALENV_PYTHON']
- except KeyError:
- pass
+ for name in ("VIRTUALENV_PYTHON", "PYTHONDONTWRITEBYTECODE"):
+ try:
+ del os.environ[name]
+ except KeyError:
+ pass
assert cwd
cwd.ensure(dir=1)
old = self.patchPATH()
diff --git a/toxbootstrap.py b/toxbootstrap.py
index 37ddef5..cae20d2 100644
--- a/toxbootstrap.py
+++ b/toxbootstrap.py
@@ -58,7 +58,7 @@ ToDo
"""
-__version__ = '1.5.0'
+__version__ = '1.5.1.dev1'
import sys
import os