summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorholger krekel <holger@merlinux.eu>2015-06-19 15:29:21 +0200
committerholger krekel <holger@merlinux.eu>2015-06-19 15:29:21 +0200
commit69f4f8f19ce728dbfdc3f8c8e3d63a31b4beebb5 (patch)
treedf9193e6284db93bd9610a8aaa14f17295b00be4
parent519dfc099f43747518187151164f9cfcc1ef09a6 (diff)
downloadtox-69f4f8f19ce728dbfdc3f8c8e3d63a31b4beebb5.tar.gz
prepare 2.1.0 release2.1.0
-rw-r--r--doc/conf.py4
-rw-r--r--doc/config.txt4
-rw-r--r--setup.py2
-rw-r--r--tox/__init__.py2
4 files changed, 8 insertions, 4 deletions
diff --git a/doc/conf.py b/doc/conf.py
index 269e8ba..630cb80 100644
--- a/doc/conf.py
+++ b/doc/conf.py
@@ -48,8 +48,8 @@ copyright = u'2015, holger krekel and others'
# built documents.
#
# The short X.Y version.
-release = "2.0"
-version = "2.0.1"
+release = "2.1"
+version = "2.1.0"
# The full version, including alpha/beta/rc tags.
# The language for content autogenerated by Sphinx. Refer to documentation
diff --git a/doc/config.txt b/doc/config.txt
index c392289..ed9290c 100644
--- a/doc/config.txt
+++ b/doc/config.txt
@@ -206,6 +206,10 @@ Complete list of settings that you can put into ``testenv*`` sections:
``TMPDIR`` will be passed down. You can override these variables
with the ``setenv`` option.
+ If defined the ``TOX_TESTENV_PASSENV`` environment variable (in the tox
+ invocation environment) can define additional space-separated variable
+ names that are to be passed down to the test command environment.
+
.. confval:: recreate=True|False(default)
Always recreate virtual environment if this option is True.
diff --git a/setup.py b/setup.py
index f297a9d..f82efb3 100644
--- a/setup.py
+++ b/setup.py
@@ -48,7 +48,7 @@ def main():
description='virtualenv-based automation of test activities',
long_description=open("README.rst").read(),
url='http://tox.testrun.org/',
- version='2.1.0.dev2',
+ version='2.1.0',
license='http://opensource.org/licenses/MIT',
platforms=['unix', 'linux', 'osx', 'cygwin', 'win32'],
author='holger krekel',
diff --git a/tox/__init__.py b/tox/__init__.py
index e3872ec..6c2cbe4 100644
--- a/tox/__init__.py
+++ b/tox/__init__.py
@@ -1,5 +1,5 @@
#
-__version__ = '2.1.0.dev2'
+__version__ = '2.1.0'
from .hookspecs import hookspec, hookimpl # noqa