summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorholger krekel <holger@merlinux.eu>2015-02-24 16:45:14 +0100
committerholger krekel <holger@merlinux.eu>2015-02-24 16:45:14 +0100
commit97d608429f8c744ce49dc6cc62e57ef22e5e18bf (patch)
treea3e199bee3106b17d041f075250fdc59e235feee
parentc68d1991561344501c15e4dd46be37648d3dc6f7 (diff)
downloadtox-97d608429f8c744ce49dc6cc62e57ef22e5e18bf.tar.gz
1.9.01.9.0
-rw-r--r--CHANGELOG2
-rw-r--r--doc/announce/release-1.9.txt66
-rw-r--r--doc/conf.py4
-rw-r--r--setup.py2
-rw-r--r--tox.ini7
-rw-r--r--tox/__init__.py2
6 files changed, 73 insertions, 10 deletions
diff --git a/CHANGELOG b/CHANGELOG
index f89891a..24084c9 100644
--- a/CHANGELOG
+++ b/CHANGELOG
@@ -1,4 +1,4 @@
-1.9.0.dev
+1.9.0
-----------
- fix issue193: Remove ``--pre`` from the default ``install_command``; by
diff --git a/doc/announce/release-1.9.txt b/doc/announce/release-1.9.txt
new file mode 100644
index 0000000..96379b9
--- /dev/null
+++ b/doc/announce/release-1.9.txt
@@ -0,0 +1,66 @@
+tox-1.9: refinements, fixes (+detox-0.9.4)
+==========================================
+
+tox-1.9 was released to pypi, a maintenance release with mostly
+backward-compatible enhancements and fixes. However, tox now defaults
+to pip-installing only non-development releases and you have to set "pip_pre =
+True" in your testenv section to have it install development ("pre") releases.
+
+In addition, there is a new detox-0.9.4 out which allow to run tox test
+environments in parallel and fixes a compat problem with eventlet.
+
+Thanks to Alexander Schepanosvki, Florian Schulze and others for the
+contributed fixes and improvements.
+
+More documentation about tox in general:
+
+ http://tox.testrun.org/
+
+Installation:
+
+ pip install -U tox
+
+code hosting and issue tracking on bitbucket:
+
+ https://bitbucket.org/hpk42/tox
+
+What is tox?
+----------------
+
+tox standardizes and automates tedious test activities driven from a
+simple ``tox.ini`` file, including:
+
+* creation and management of different virtualenv environments
+ with different Python interpreters
+* packaging and installing your package into each of them
+* running your test tool of choice, be it nose, py.test or unittest2 or other tools such as "sphinx" doc checks
+* testing dev packages against each other without needing to upload to PyPI
+
+best,
+Holger Krekel, merlinux GmbH
+
+
+1.9.0
+-----------
+
+- fix issue193: Remove ``--pre`` from the default ``install_command``; by
+ default tox will now only install final releases from PyPI for unpinned
+ dependencies. Use ``pip_pre = true`` in a testenv or the ``--pre``
+ command-line option to restore the previous behavior.
+
+- fix issue199: fill resultlog structure ahead of virtualenv creation
+
+- refine determination if we run from Jenkins, thanks Borge Lanes.
+
+- echo output to stdout when ``--report-json`` is used
+
+- fix issue11: add a ``skip_install`` per-testenv setting which
+ prevents the installation of a package. Thanks Julian Krause.
+
+- fix issue124: ignore command exit codes; when a command has a "-" prefix,
+ tox will ignore the exit code of that command
+
+- fix issue198: fix broken envlist settings, e.g. {py26,py27}{-lint,}
+
+- fix issue191: lessen factor-use checks
+
diff --git a/doc/conf.py b/doc/conf.py
index 3096b10..9c573d7 100644
--- a/doc/conf.py
+++ b/doc/conf.py
@@ -48,8 +48,8 @@ copyright = u'2013, holger krekel and others'
# built documents.
#
# The short X.Y version.
-release = "1.8"
-version = "1.8.1"
+release = "1.9"
+version = "1.9.0"
# The full version, including alpha/beta/rc tags.
# The language for content autogenerated by Sphinx. Refer to documentation
diff --git a/setup.py b/setup.py
index 46730a0..8d14f26 100644
--- a/setup.py
+++ b/setup.py
@@ -26,7 +26,7 @@ def main():
description='virtualenv-based automation of test activities',
long_description=open("README.rst").read(),
url='http://tox.testrun.org/',
- version='1.8.2.dev1',
+ version='1.9.0',
license='http://opensource.org/licenses/MIT',
platforms=['unix', 'linux', 'osx', 'cygwin', 'win32'],
author='holger krekel',
diff --git a/tox.ini b/tox.ini
index 6bcca5e..97a1ac1 100644
--- a/tox.ini
+++ b/tox.ini
@@ -1,5 +1,5 @@
[tox]
-envlist=py27,py26,py34,py33,py32,pypy,flakes
+envlist=py27,py26,py34,py33,pypy,flakes
[testenv:X]
commands=echo {posargs}
@@ -14,7 +14,7 @@ changedir=doc
deps=sphinx
{[testenv]deps}
commands=
- py.test -v \
+ py.test -v
--junitxml={envlogdir}/junit-{envname}.xml \
check_sphinx.py {posargs}
@@ -22,9 +22,6 @@ commands=
deps = pytest-flakes>=0.2
commands = py.test --flakes -m flakes tox tests
-[testenv:py25]
-setenv= PIP_INSECURE=1
-
[pytest]
rsyncdirs=tests tox
addopts = -rsxXf
diff --git a/tox/__init__.py b/tox/__init__.py
index 6797068..8529f71 100644
--- a/tox/__init__.py
+++ b/tox/__init__.py
@@ -1,5 +1,5 @@
#
-__version__ = '1.8.2.dev1'
+__version__ = '1.9.0'
class exception:
class Error(Exception):