summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorholger krekel <holger@merlinux.eu>2011-05-27 15:01:44 +0200
committerholger krekel <holger@merlinux.eu>2011-05-27 15:01:44 +0200
commitce6dc78b2700bda9b8bdb14b5049ef96bebb8125 (patch)
tree4afd0f01d2653a7f8018cca6194b7c2c85643342
parenta94597d4e31549e16944706264638a9933e28e1f (diff)
downloadtox-ce6dc78b2700bda9b8bdb14b5049ef96bebb8125.tar.gz
fix toxbootstrap links and fix a test that failed on windows for escaping reasons
-rw-r--r--CHANGELOG.txt2
-rw-r--r--doc/example/jenkins.txt4
-rw-r--r--setup.py2
-rw-r--r--tests/test_venv.py4
-rw-r--r--tox/__init__.py2
-rw-r--r--toxbootstrap.py4
6 files changed, 10 insertions, 8 deletions
diff --git a/CHANGELOG.txt b/CHANGELOG.txt
index be51e9b..425739e 100644
--- a/CHANGELOG.txt
+++ b/CHANGELOG.txt
@@ -1,5 +1,7 @@
1.0
-----------------
+
+- move repository and toxbootstrap links to http://bitbucket.org/hpk42/tox
- fix issue7: introduce a "minversion" directive such that tox
bails out if it does not have the correct version.
- fix issue24: introduce a way to set environment variables for
diff --git a/doc/example/jenkins.txt b/doc/example/jenkins.txt
index ad26f60..a2bdb6b 100644
--- a/doc/example/jenkins.txt
+++ b/doc/example/jenkins.txt
@@ -48,7 +48,7 @@ installing ``tox`` then substitute the above **Python build step** code
with this::
import urllib, os
- url = "https://pytox.googlecode.com/hg/toxbootstrap.py"
+ url = "https://bitbucket.org/hpk42/tox/raw/default/toxbootstrap.py"
#os.environ['USETOXDEV']="1" # use tox dev version
d = dict(__file__='toxbootstrap.py')
exec urllib.urlopen(url).read() in d
@@ -65,7 +65,7 @@ install ``tox`` in a virtual sub environment. Notes:
will cause tox to reinstall all virtual environments all the time
which is often what one wants in CI server contexts)
-.. _`toxbootstrap.py`: https://pytox.googlecode.com/hg/toxbootstrap.py
+.. _`toxbootstrap.py`: https://bitbucket.org/hpk42/tox/raw/default/toxbootstrap.py
Integrating "sphinx" documentation checks in a Jenkins job
----------------------------------------------------------------
diff --git a/setup.py b/setup.py
index 1134e42..d489599 100644
--- a/setup.py
+++ b/setup.py
@@ -33,7 +33,7 @@ def main():
description='virtualenv-based automation of test activities',
long_description=long_description,
url='http://codespeak.net/tox',
- version='1.0.dev5',
+ version='1.0.dev6',
license='GPLv2 or later',
platforms=['unix', 'linux', 'osx', 'cygwin', 'win32'],
author='holger krekel',
diff --git a/tests/test_venv.py b/tests/test_venv.py
index 25f3d70..4d884ba 100644
--- a/tests/test_venv.py
+++ b/tests/test_venv.py
@@ -376,10 +376,10 @@ class TestVenvTest:
def test_setenv_added_to_pcall(mocksession, newconfig):
config = newconfig([], """
[testenv:python]
- commands=%s -V
+ commands=python -V
setenv =
ENV_VAR = value
- """ % sys.executable)
+ """)
mocksession._clearmocks()
venv = VirtualEnv(config.envconfigs['python'], session=mocksession)
diff --git a/tox/__init__.py b/tox/__init__.py
index a33104e..ba7678b 100644
--- a/tox/__init__.py
+++ b/tox/__init__.py
@@ -1,5 +1,5 @@
#
-__version__ = '1.0.dev5'
+__version__ = '1.0.dev6'
class exception:
class Error(Exception):
diff --git a/toxbootstrap.py b/toxbootstrap.py
index cf961ba..9c7f40d 100644
--- a/toxbootstrap.py
+++ b/toxbootstrap.py
@@ -36,7 +36,7 @@ Getting started
$ cd my_project/
$ ls
. .. src/ doc/ setup.py tox.ini
- $ curl http://pytox.googlecode.com/hg/toxbootstrap.py -O
+ $ curl https://bitbucket.org/hpk42/tox/raw/default/toxbootstrap.py
Instead of running "tox", now you can just run "python toxbootstrap.py" which
will take care of installing tox (if not already installed into
@@ -58,7 +58,7 @@ ToDo
"""
-__version__ = '1.0.dev5'
+__version__ = '1.0.dev6'
import sys
import os