summaryrefslogtreecommitdiff
path: root/pyproject.toml
diff options
context:
space:
mode:
Diffstat (limited to 'pyproject.toml')
-rw-r--r--pyproject.toml10
1 files changed, 5 insertions, 5 deletions
diff --git a/pyproject.toml b/pyproject.toml
index 19ee5ec5..87c2ce55 100644
--- a/pyproject.toml
+++ b/pyproject.toml
@@ -52,8 +52,8 @@ dependencies = [
"chardet>=5.1",
"colorama>=0.4.6",
"filelock>=3.11",
- 'importlib-metadata>=6.2; python_version < "3.8"',
- "packaging>=23",
+ 'importlib-metadata>=6.4.1; python_version < "3.8"',
+ "packaging>=23.1",
"platformdirs>=3.2",
"pluggy>=1",
"pyproject-api>=1.5.1",
@@ -65,8 +65,8 @@ optional-dependencies.docs = [
"furo>=2023.3.27",
"sphinx>=6.1.3",
"sphinx-argparse-cli>=1.11",
- "sphinx-autodoc-typehints!=1.23.4,>=1.22",
- "sphinx-copybutton>=0.5.1",
+ "sphinx-autodoc-typehints!=1.23.4,>=1.23",
+ "sphinx-copybutton>=0.5.2",
"sphinx-inline-tabs>=2022.1.2b11",
"sphinxcontrib-towncrier>=0.2.1a0",
"towncrier>=22.12",
@@ -81,7 +81,7 @@ optional-dependencies.testing = [
"hatch-vcs>=0.3",
"hatchling>=1.14",
"psutil>=5.9.4",
- "pytest>=7.2.2",
+ "pytest>=7.3.1",
"pytest-cov>=4",
"pytest-mock>=3.10",
"pytest-xdist>=3.2.1",