summaryrefslogtreecommitdiff
path: root/tox.ini
diff options
context:
space:
mode:
authorBernát Gábor <gaborjbernat@gmail.com>2023-04-05 09:20:49 -0700
committerGitHub <noreply@github.com>2023-04-05 09:20:49 -0700
commitf6e3dc97d0ecf1caa310b377ae948338c6fa67b8 (patch)
treec178410c25b5757efc41c9f411a33e1a31061be1 /tox.ini
parent82584c900fddc5422b241e294e87cd72de5078c9 (diff)
downloadtox-git-f6e3dc97d0ecf1caa310b377ae948338c6fa67b8.tar.gz
Bump deps and tools (#2976)
Diffstat (limited to 'tox.ini')
-rw-r--r--tox.ini20
1 files changed, 10 insertions, 10 deletions
diff --git a/tox.ini b/tox.ini
index f86aedf6..61f87461 100644
--- a/tox.ini
+++ b/tox.ini
@@ -1,4 +1,5 @@
[tox]
+minversion = 3.22
envlist =
fix
py311
@@ -12,18 +13,19 @@ envlist =
pkg_meta
isolated_build = true
skip_missing_interpreters = true
-minversion = 3.22
[testenv]
description = run the tests with pytest under {envname}
+package = wheel
+wheel_build_env = .pkg
+extras =
+ testing
passenv =
PYTEST_*
SSL_CERT_FILE
setenv =
COVERAGE_FILE = {env:COVERAGE_FILE:{toxworkdir}{/}.coverage.{envname}}
COVERAGE_PROCESS_START = {toxinidir}{/}pyproject.toml
-extras =
- testing
commands =
pytest {posargs: \
--junitxml {toxworkdir}{/}junit.{envname}.xml --cov {envsitepackagesdir}{/}tox --cov {toxinidir}{/}tests \
@@ -33,17 +35,15 @@ commands =
-n={env:PYTEST_XDIST_AUTO_NUM_WORKERS:auto} \
tests --durations 5 --run-integration}
diff-cover --compare-branch {env:DIFF_AGAINST:origin/main} {toxworkdir}{/}coverage.{envname}.xml
-package = wheel
-wheel_build_env = .pkg
[testenv:fix]
description = format the code base to adhere to our styles, and complain about what we cannot do automatically
+skip_install = true
+deps =
+ pre-commit>=3.2.1
passenv =
{[testenv]passenv}
PROGRAMDATA
-skip_install = true
-deps =
- pre-commit>=3.2
commands =
pre-commit run --all-files --show-diff-on-failure {posargs}
python -c 'print(r"hint: run {envbindir}{/}pre-commit install to add checks as pre-commit hook")'
@@ -52,8 +52,8 @@ commands =
description = run type check on code base
deps =
mypy==1.1.1
- types-cachetools>=5.3.0.4
- types-chardet>=5.0.4.2
+ types-cachetools>=5.3.0.5
+ types-chardet>=5.0.4.3
commands =
mypy src/tox
mypy tests