summaryrefslogtreecommitdiff
path: root/tox.ini
diff options
context:
space:
mode:
authorBernát Gábor <gaborjbernat@gmail.com>2022-03-04 10:32:30 +0000
committerGitHub <noreply@github.com>2022-03-04 10:32:30 +0000
commitdbbcb37a816b0fbc72280ef26aeca7dece8b2858 (patch)
treef9e7901262a539116daa4e8687db087ab36eee4c /tox.ini
parentaee461a8988b7a29bfc41e21127d810a1e1f5ddb (diff)
downloadtox-git-dbbcb37a816b0fbc72280ef26aeca7dece8b2858.tar.gz
Use hatchling instead of setuptools as build backend (#2369)
Diffstat (limited to 'tox.ini')
-rw-r--r--tox.ini13
1 files changed, 11 insertions, 2 deletions
diff --git a/tox.ini b/tox.ini
index 349d2955..4275a543 100644
--- a/tox.ini
+++ b/tox.ini
@@ -18,13 +18,13 @@ passenv =
SSL_CERT_FILE
setenv =
COVERAGE_FILE = {env:COVERAGE_FILE:{toxworkdir}{/}.coverage.{envname}}
- COVERAGE_PROCESS_START = {toxinidir}{/}setup.cfg
+ COVERAGE_PROCESS_START = {toxinidir}{/}pyproject.toml
extras =
testing
commands =
pytest {tty:--color=yes} {posargs: \
--junitxml {toxworkdir}{/}junit.{envname}.xml --cov {envsitepackagesdir}{/}tox --cov {toxinidir}{/}tests \
- --cov-config=setup.cfg --no-cov-on-fail --cov-report term-missing:skip-covered --cov-context=test \
+ --cov-config={toxinidir}{/}pyproject.toml --no-cov-on-fail --cov-report term-missing:skip-covered --cov-context=test \
--cov-report html:{envtmpdir}{/}htmlcov \
--cov-report xml:{toxworkdir}{/}coverage.{envname}.xml \
-n={env:PYTEST_XDIST_PROC_NR:auto} \
@@ -99,3 +99,12 @@ extras =
commands =
python -m pip list --format=columns
python -c "print(r'{envpython}')"
+
+[flake8]
+max-complexity = 22
+max-line-length = 120
+unused-arguments-ignore-abstract-functions = true
+noqa-require-code = true
+ignore =
+ E203 # whitespace before ':'
+ W503 # line break before binary operator