summaryrefslogtreecommitdiff
path: root/tox.ini
diff options
context:
space:
mode:
authorGábor Bernát <jokerjokerer@gmail.com>2017-09-07 14:58:48 +0100
committerOliver Bestwalter <oliver@bestwalter.de>2017-09-07 15:58:48 +0200
commitac38ca4bb197338a352a0ce43c656fbdb74f2ffd (patch)
tree251f81f7a5751a9e15a40b0725a7cb649e889d79 /tox.ini
parentdf08108799656d3d56ffcd0ffdfecfbb48af9545 (diff)
downloadtox-git-ac38ca4bb197338a352a0ce43c656fbdb74f2ffd.tar.gz
[STYLE] Move to flake8, add bugbear, and also check doc and setup.py files (#581)
* [STYLE] Move to flake8, add bugbear, and also check doc and setup.py files - removed some errors from global list and made it locally ignored - pin point versions for linters so that release of new versions do not break CI tests that were successful previously * fix tuple instead of string arg see: https://ci.appveyor.com/project/RonnyPfannschmidt/tox/build/1.0.346/job/b6wmkvut8k8k6tpt * fix import on Windows
Diffstat (limited to 'tox.ini')
-rw-r--r--tox.ini24
1 files changed, 11 insertions, 13 deletions
diff --git a/tox.ini b/tox.ini
index c2f6c05e..39e9bec9 100644
--- a/tox.ini
+++ b/tox.ini
@@ -1,5 +1,5 @@
[tox]
-envlist = py27,py26,py34,py33,py35,py36,pypy,flakes,py26-bare,docs
+envlist = py27,py26,py34,py33,py35,py36,pypy,style,py26-bare,docs
minversion = 2.7.0
[testenv]
@@ -29,12 +29,16 @@ passenv = http_proxy https_proxy no_proxy SSL_CERT_FILE
commands = sphinx-build -d .tox/docs_doctree doc .tox/docs_out --color -W -bhtml
sphinx-build -d .tox/docs_doctree doc .tox/docs_out --color -W -blinkcheck
-[testenv:flakes]
-deps = pytest-flakes >= 0.2
- pytest-pep8
-description = run static analysis and style check using flakes and pep-8
-commands = pytest --flakes -m flakes tox tests
- pytest --pep8 -m pep8 tox tests
+[testenv:style]
+basepython = python3.6
+deps = flake8 == 3.4.1
+ flake8-bugbear == 17.4.0
+description = run static analysis and style check using flake8
+commands = python -m flake8 --show-source tox setup.py {posargs}
+ python -m flake8 --show-source doc tests {posargs}
+[flake8]
+max-complexity = 22
+max-line-length = 99
[testenv:py26-bare]
description = invoke the tox help message under Python 2.6
@@ -87,10 +91,4 @@ addopts = -rsxX
rsyncdirs = tests tox
looponfailroots = tox tests
norecursedirs = .hg .tox
-pep8maxlinelength = 99
-# W503 - line break before binary operator
-# E402 - module level import not at top of file
-# E731 - do not assign a lambda expression, use a def
-pep8ignore = *.py W503 E402 E731
-flakes-ignore = ImportStarUsage
xfail_strict = True