summaryrefslogtreecommitdiff
path: root/tasks
diff options
context:
space:
mode:
authorOliver Bestwalter <oliver.bestwalter@avira.com>2018-04-02 18:05:14 +0200
committerOliver Bestwalter <oliver.bestwalter@avira.com>2018-04-02 23:27:43 +0200
commitf3386910dd0aa92dca81dd2a079744ad4b31729d (patch)
treed6bf0da08a5bbf078d367f1d037eab5225bf0fa9 /tasks
parent558f18b74e3ecfc203963165fcc8af15ba6673d4 (diff)
downloadtox-git-f3386910dd0aa92dca81dd2a079744ad4b31729d.tar.gz
add a separate build step to pra script
(cherry picked from commit 35f8247)
Diffstat (limited to 'tasks')
-rwxr-xr-xtasks/pra.sh6
1 files changed, 6 insertions, 0 deletions
diff --git a/tasks/pra.sh b/tasks/pra.sh
index c1433f8a..ab02b7ba 100755
--- a/tasks/pra.sh
+++ b/tasks/pra.sh
@@ -7,6 +7,7 @@ set -e
if [ -z "$1" ]; then
echo "workflow: $0 <command> [arg]"
echo " prep <version>"
+ echo " build"
echo " upload <devpi username>"
echo " test (optional)"
echo " release"
@@ -28,6 +29,8 @@ dispatch () {
exit 1
fi
prep
+ elif [ "$1" == "build" ]; then
+ build
elif [ "$1" == "upload" ]; then
devpi_upload $2
elif [ "$1" == "test" ]; then
@@ -50,6 +53,9 @@ prep () {
_confirm "commit changelog and tag repo as ${VERSION}?"
git commit -m "release preparation for ${VERSION}" || true
git tag -s ${VERSION} -m "release tox ${VERSION}" || true
+}
+
+build () {
rm dist/tox* || true
python setup.py sdist bdist_wheel
pip install -U dist/tox-${VERSION}.tar.gz