summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorOliver Bestwalter <oliver.bestwalter@avira.com>2017-03-12 22:28:17 +0100
committerOliver Bestwalter <oliver.bestwalter@avira.com>2017-03-12 22:28:17 +0100
commita043ea8ed3eb20b045fbd2d9722c83b2f600b730 (patch)
tree23764e96210b98c05c5fa2122a5af0fbcdb1d881 /setup.py
parent35231d41c7493456e67f0f18050588a0184c1963 (diff)
downloadtox-git-a043ea8ed3eb20b045fbd2d9722c83b2f600b730.tar.gz
start using setuptools_scm
setuptools_scm removes the need to maintain versions numbers in the source code. This commit removes all code that was needed due to manually handling version numbers. * remove _getdoctarget.py which was a helper to fetch the version for sphinx * remove SITETARGET using that script as it is very likely obsolete asI can't find any usage or references to this * fetch version from pkg_resources instead
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py3
1 files changed, 2 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index 686845ae..76b5a3fe 100644
--- a/setup.py
+++ b/setup.py
@@ -55,13 +55,14 @@ def main():
description='virtualenv-based automation of test activities',
long_description=open("README.rst").read(),
url='https://tox.readthedocs.org/',
- version='2.6.1.dev1',
+ use_scm_version=True,
license='http://opensource.org/licenses/MIT',
platforms=['unix', 'linux', 'osx', 'cygwin', 'win32'],
author='holger krekel',
author_email='holger@merlinux.eu',
packages=['tox'],
entry_points={'console_scripts': 'tox=tox:cmdline\ntox-quickstart=tox._quickstart:main'},
+ setup_requires=['setuptools_scm'],
# we use a public tox version to test, see tox.ini's testenv
# "deps" definition for the required dependencies
tests_require=['tox'],