diff options
author | Gábor Bernát <jokerjokerer@gmail.com> | 2017-09-06 18:45:27 +0100 |
---|---|---|
committer | Oliver Bestwalter <oliver@bestwalter.de> | 2017-09-06 19:45:27 +0200 |
commit | babcb42cdcbc46e2e5f8a01ab807415b289777b7 (patch) | |
tree | a59bdf3ee07858092991c2702a64074bfdb64d56 /setup.py | |
parent | 8a46ec7588fd4f397d426c75986aab3284d48944 (diff) | |
download | tox-git-babcb42cdcbc46e2e5f8a01ab807415b289777b7.tar.gz |
move documentation from txt to rst files (#583)
* move documentation from txt to rst files
* remove announce data as this is already present now in changelog
* [DOCS] General fixes
- move to tox sphinx-build command from pytest, so the documentation
can be explored afterwards, and threat warnings as errors, so they are
not ignored
- fix links that no longer exist or redirect permenantly
- make literals code blocks with appropiate syntax highlighting
- remove generated commented lines from conf.py
- add SSL_CERT_FILE env variable sphinxs tls_cacerts so that it will
work behind corporate proxies
* [DOCS] add external links for Github issues, pull requests and users in changelog
* [DOCS] consolidate documentation information to match various platforms
and avoid redundancy
* [DOCS] still show links to legacy release changelogs
Diffstat (limited to 'setup.py')
-rw-r--r-- | setup.py | 4 |
1 files changed, 2 insertions, 2 deletions
@@ -41,8 +41,8 @@ def has_environment_marker_support(): def get_linked_changelog(here, n=5): """changelog containing last n releases with links to issues""" repo_url = 'https://github.com/tox-dev/tox' - changelog_url = '%s/blob/master/CHANGELOG' % repo_url - with io.open(os.path.join(here, 'CHANGELOG'), encoding='utf-8') as f: + changelog_url = '%s/blob/master/CHANGELOG.rst' % repo_url + with io.open(os.path.join(here, 'CHANGELOG.rst'), encoding='utf-8') as f: changelog = f.read() header_matches = list(re.finditer('^-+$', changelog, re.MULTILINE)) lines = changelog[:header_matches[n].start()].splitlines()[:-1] |