summaryrefslogtreecommitdiff
path: root/pyproject.toml
diff options
context:
space:
mode:
authorStephen Finucane <stephen@that.guru>2023-01-11 15:55:51 +0000
committerGitHub <noreply@github.com>2023-01-11 07:55:51 -0800
commit9f89f51bce04817c81ffad8979ac2a9138e0777a (patch)
tree7983a8f8fb336a7c33ef2b20204e2bb1b62f501b /pyproject.toml
parent34b79a2514f8ab1675d6b928fa7e83268c8bd78e (diff)
downloadtox-git-9f89f51bce04817c81ffad8979ac2a9138e0777a.tar.gz
Revert to supporting simple Python factors (#2849)
Co-authored-by: Bernát Gábor <bgabor8@bloomberg.net> Co-authored-by: pre-commit-ci[bot] <66853113+pre-commit-ci[bot]@users.noreply.github.com> Fixes https://github.com/tox-dev/tox/issues/2657 Fixes https://github.com/tox-dev/tox/issues/2848
Diffstat (limited to 'pyproject.toml')
-rw-r--r--pyproject.toml18
1 files changed, 9 insertions, 9 deletions
diff --git a/pyproject.toml b/pyproject.toml
index e4d5ad96..e8be85ac 100644
--- a/pyproject.toml
+++ b/pyproject.toml
@@ -1,6 +1,6 @@
[build-system]
build-backend = "hatchling.build"
-requires = ["hatchling>=1.12", "hatch-vcs>=0.3"]
+requires = ["hatchling>=1.12.2", "hatch-vcs>=0.3"]
[project]
name = "tox"
@@ -22,24 +22,24 @@ maintainers = [
]
requires-python = ">=3.7"
dependencies = [
- "cachetools>=5.2",
+ "cachetools>=5.2.1",
"chardet>=5.1",
"colorama>=0.4.6",
- "packaging>=22",
+ "packaging>=23",
"platformdirs>=2.6.2",
"pluggy>=1",
- "pyproject-api>=1.2.1",
+ "pyproject-api>=1.4",
'tomli>=2.0.1; python_version < "3.11"',
"virtualenv>=20.17.1",
"filelock>=3.9",
- 'importlib-metadata>=5.2; python_version < "3.8"',
+ 'importlib-metadata>=6; python_version < "3.8"',
'typing-extensions>=4.4; python_version < "3.8"',
]
optional-dependencies.docs = [
"furo>=2022.12.7",
- "sphinx>=6",
- "sphinx-argparse-cli>=1.10",
- "sphinx-autodoc-typehints>=1.19.5",
+ "sphinx>=6.1.3",
+ "sphinx-argparse-cli>=1.11",
+ "sphinx-autodoc-typehints>=1.20.1",
"sphinx-copybutton>=0.5.1",
"sphinx-inline-tabs>=2022.1.2b11",
"sphinxcontrib-towncrier>=0.2.1a0",
@@ -53,7 +53,7 @@ optional-dependencies.testing = [
"distlib>=0.3.6",
"flaky>=3.7",
"hatch-vcs>=0.3",
- "hatchling>=1.12",
+ "hatchling>=1.12.2",
"psutil>=5.9.4",
"pytest>=7.2",
"pytest-cov>=4",