summaryrefslogtreecommitdiff
path: root/changelog/template.jinja2
diff options
context:
space:
mode:
authorOliver Bestwalter <oliver@bestwalter.de>2017-09-29 13:57:10 +0200
committerGitHub <noreply@github.com>2017-09-29 13:57:10 +0200
commit2657331c76ae97c507e3fbc12c863a3e54c8b48a (patch)
tree5cd8d6bc51d983caffb1cacffe19ff7f8699201f /changelog/template.jinja2
parenta726aabf92801ce208ed60ac5a54b981cde0de6f (diff)
downloadtox-git-2657331c76ae97c507e3fbc12c863a3e54c8b48a.tar.gz
Add/update release and contributor howtos and adapt to how pytest does stuff (#636)
* pyproject: categories and fine tuning * add own towncrier template and changelog dir * repair changelog and add preamble about versioning, compat and projects * make sure h1 is h1 in changelog * towncrier changes * use new towncrier functionality render different formats * fix header levels * remove old formatters * add towncrier readme * example * add little script to render user name links in news * don't rerender * remove trailing whitespace * add filename * formatting * add wip release helper * replace user, issues and prs with links * add a rudimentary readme for contrib * add a rudimentary readme for contrib * working on release script * fix up release helpers * fix link in readme * nming things, remove unused variable * fix version param * add tox env for release * remove installation - done in tox env * fix running release-helper in toxenv * re-add 2.8.2 entry that has gone missing * scripts and docs for release process * remove unnecessary devpi adjustments * fix towncrier draft check as part of sphinx build * trim description * fix formatting * fix link * docs fixes * fragment inclusion in normal docs build on import of `conf.py` caused readthedocs builds to fail (https://readthedocs.org/projects/tox/builds/5956259/). Adapted code and moved it into pre-process script to be integrated in a more robust way later, if deemed necessary but for now it has to be enough to generate and integrate newsfragments only as part of a release. * fix name of element passed from towncrier for issue links (issue) * use toxworkdir for sphinx-build path * fix header levels in changelog to make changelog header level 1 * docs fixes * fragment inclusion in normal docs build on import of `conf.py` caused readthedocs builds to fail (https://readthedocs.org/projects/tox/builds/5956259/). Adapted code and moved it into pre-process script to be integrated in a more robust way later, if deemed necessary but for now it has to be enough to generate and integrate newsfragments only as part of a release. * fix name of element passed from towncrier for issue links (issue) * use toxworkdir for sphinx-build path * fix header levels in changelog to make changelog header level 1 * remove obsolete fragments inclusion * remove unnecessary readme * remove unnecessary distinction between issue and pr * shamelessly steal contributing from pytest to adapt for tox * s/pytest/tox * remove branching info - does not apply to tox * fix line endings * fix changelog location (like in pytest project) * contributor docs, templates, towncrier fixes, adjust envname to pytest * Sort contributors alphabetically like pytest does it * prune, refine and reorder contributor docs * refine towncrier docs * fix typo in contributor name * fix grammar * fix code block declaration * removed one colon too much * revert unnecessary assignment * fix env name for style checks * fix typo in pre-commit hint * just alias main until (if ever) more functions grow here.
Diffstat (limited to 'changelog/template.jinja2')
-rw-r--r--changelog/template.jinja231
1 files changed, 31 insertions, 0 deletions
diff --git a/changelog/template.jinja2 b/changelog/template.jinja2
new file mode 100644
index 00000000..cb98bf09
--- /dev/null
+++ b/changelog/template.jinja2
@@ -0,0 +1,31 @@
+{% for section, _ in sections.items() %}
+{% set underline = underlines[0] %}
+{% if section %}
+{{section}}
+{{ underline * section|length }}
+{% set underline = underlines[1] %}
+{% endif %}
+
+{% if sections[section] %}
+{% for category, val in definitions.items() if category in sections[section] %}
+{{ definitions[category]['name'] }}
+{{ underline * definitions[category]['name']|length }}
+{% if definitions[category]['showcontent'] %}
+
+{% for text, values in sections[section][category].items() %}
+- {{ text }} ({{ values|join(', ') }})
+{% endfor %}
+
+{% else %}
+- {{ sections[section][category]['']|join(', ') }}
+{% endif %}
+
+{% if sections[section][category]|length == 0 %}
+No significant changes.
+{% endif %}
+{% endfor %}
+
+{% else %}
+No significant changes.
+{% endif %}
+{% endfor %}