summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernát Gábor <gaborjbernat@gmail.com>2018-09-12 19:12:35 +0100
committerGitHub <noreply@github.com>2018-09-12 19:12:35 +0100
commit32795265f7b4c75f766b183928c8e0df2582eca9 (patch)
treea5440075c552911c336d4bdcae3e8565848a982b
parent89b5bdfdafea7e5737663918eff3613b55771b21 (diff)
downloadtox-git-32795265f7b4c75f766b183928c8e0df2582eca9.tar.gz
switch to isolated build (#971)
-rw-r--r--.vsts-ci.yml10
-rw-r--r--pyproject.toml3
-rw-r--r--tox.ini3
3 files changed, 9 insertions, 7 deletions
diff --git a/.vsts-ci.yml b/.vsts-ci.yml
index b4134316..b1bd0ddc 100644
--- a/.vsts-ci.yml
+++ b/.vsts-ci.yml
@@ -20,7 +20,7 @@ jobs:
inputs:
versionSpec: '3.7'
- - script: 'python -m pip install -U tox setuptools'
+ - script: 'python -m pip install -U tox'
displayName: install tox
- script: 'tox -e fix-lint'
@@ -45,7 +45,7 @@ jobs:
inputs:
versionSpec: '3.7'
- - script: 'python -m pip install -U tox setuptools'
+ - script: 'python -m pip install -U tox'
displayName: install tox
- script: 'tox -e $(toxenv)'
@@ -74,7 +74,7 @@ jobs:
inputs:
versionSpec: '$(python.version)'
- - script: 'python -m pip install -U tox setuptools'
+ - script: 'python -m pip install -U tox'
displayName: install tox
- script: 'python -m tox -e py --notest'
@@ -132,7 +132,7 @@ jobs:
inputs:
versionSpec: '$(python.version)'
- - script: 'python -m pip install -U tox setuptools'
+ - script: 'python -m pip install -U tox'
displayName: install tox
- script: 'python -m tox -e py --notest'
@@ -174,7 +174,7 @@ jobs:
toxenv: 'py3'
steps:
- - script: 'python3 -m pip install -U tox setuptools'
+ - script: 'python3 -m pip install -U tox'
displayName: install tox
- script: 'python3 -m tox -e $(toxenv) --notest'
diff --git a/pyproject.toml b/pyproject.toml
index deec8901..89839548 100644
--- a/pyproject.toml
+++ b/pyproject.toml
@@ -1,9 +1,10 @@
[build-system]
requires = [
"setuptools >= 35.0.2",
- "setuptools_scm >= 2.0.0, <3",
+ "setuptools_scm >= 2.0.0, <4",
"wheel >= 0.29.0",
]
+build-backend = 'setuptools.build_meta'
[tool.towncrier]
package = "tox"
diff --git a/tox.ini b/tox.ini
index 67c2c5b9..98eeaa7b 100644
--- a/tox.ini
+++ b/tox.ini
@@ -9,7 +9,8 @@ envlist = py27,
fix-lint,
docs,
package-description
-minversion = 2.9.0
+minversion = 3.3.0
+isolated_build = true
skip_missing_interpreters = true
[testenv]