summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernat Gabor <bgabor8@bloomberg.net>2019-12-27 18:12:11 +0000
committerBernat Gabor <bgabor8@bloomberg.net>2019-12-28 09:52:57 +0000
commit1b8f302f8d3c083fbf54dde48457aa190995d409 (patch)
tree2a954eb4bac284b86ec93a0313300f01c63687f5
parent0c591b9e30830fad0dec15401e45b59ed32b2519 (diff)
downloadtox-git-1b8f302f8d3c083fbf54dde48457aa190995d409.tar.gz
release 3.14.33.14.3
Signed-off-by: Bernat Gabor <bgabor8@bloomberg.net>
-rw-r--r--docs/changelog.rst15
-rw-r--r--docs/changelog/1478.misc.rst1
-rw-r--r--tests/integration/test_package_int.py3
-rw-r--r--tests/unit/test_result.py2
-rw-r--r--tox.ini2
5 files changed, 17 insertions, 6 deletions
diff --git a/docs/changelog.rst b/docs/changelog.rst
index ed99f791..d064f2b2 100644
--- a/docs/changelog.rst
+++ b/docs/changelog.rst
@@ -11,6 +11,21 @@ with advance notice in the **Deprecations** section of releases.
.. towncrier release notes start
+v3.14.3 (2019-12-27)
+--------------------
+
+Bugfixes
+^^^^^^^^
+
+- Relax importlib requirement to allow either version 0 or 1 - by :user:`chyzzqo2`
+ `#1476 <https://github.com/tox-dev/tox/issues/1476>`_
+
+Miscellaneous
+^^^^^^^^^^^^^
+
+- Clarify legacy setup.py error message: python projects should commit to a strong consistency of message regarding packaging. We no-longer tell people to add a setup.py to their already configured pep-517 project, otherwise it could imply that pyproject.toml isn't as well supported and recommended as it truly is - by :user:`graingert`
+ `#1478 <https://github.com/tox-dev/tox/issues/1478>`_
+
v3.14.2 (2019-12-02)
--------------------
diff --git a/docs/changelog/1478.misc.rst b/docs/changelog/1478.misc.rst
deleted file mode 100644
index 4ad6bb41..00000000
--- a/docs/changelog/1478.misc.rst
+++ /dev/null
@@ -1 +0,0 @@
-Clarify legacy setup.py error message: python projects should commit to a strong consistency of message regarding packaging. We no-longer tell people to add a setup.py to their already configured pep-517 project, otherwise it could imply that pyproject.toml isn't as well supported and recommended as it truly is - by :user:graingert
diff --git a/tests/integration/test_package_int.py b/tests/integration/test_package_int.py
index 6a34f01d..a982c2a0 100644
--- a/tests/integration/test_package_int.py
+++ b/tests/integration/test_package_int.py
@@ -78,9 +78,6 @@ def test_package_flit(initproj, cmd):
@pytest.mark.network
@pytest.mark.skipif(sys.version_info < (3, 0), reason="poetry is Python 3 only")
-@pytest.mark.xfail(
- os.name == "nt", reason="https://github.com/tobgu/pyrsistent/issues/88 breaks poetry install",
-)
def test_package_poetry(initproj, cmd):
initproj(
"magic-0.1",
diff --git a/tests/unit/test_result.py b/tests/unit/test_result.py
index 51aa9f80..d4560bd9 100644
--- a/tests/unit/test_result.py
+++ b/tests/unit/test_result.py
@@ -85,7 +85,7 @@ def test_invocation_error(exit_code, os_name, mocker, monkeypatch):
assert call_args == mocker.call("InvocationError", "<command>", exit_code)
if exit_code is None:
assert "(exited with code" not in result
- elif exit_code is -15:
+ elif exit_code == -15:
assert "(exited with code -15 (SIGTERM))" in result
else:
assert "(exited with code %d)" % exit_code in result
diff --git a/tox.ini b/tox.ini
index c8171872..89abc91a 100644
--- a/tox.ini
+++ b/tox.ini
@@ -75,7 +75,7 @@ commands = pre-commit run --all-files --show-diff-on-failure {posargs}
description = [run locally after tests]: combine coverage data and create report;
generates a diff coverage against origin/master (can be changed by setting DIFF_AGAINST env var)
deps = {[testenv]deps}
- coverage >= 4.4.1, < 5
+ coverage >= 5.0.1, < 6
diff_cover
skip_install = True
passenv = {[testenv]passenv}