summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Grainger <tagrain@gmail.com>2019-12-02 12:25:09 +0000
committerBernát Gábor <bgabor8@bloomberg.net>2019-12-02 12:25:09 +0000
commit057894f95a4979756f1e8dfdfdcc8efc51b0ad6a (patch)
treed263408ed83581bd83e4b39ac3538776b05fae9c
parentc420d01a3daf5cb01de3cd3e09c96a600cc8b522 (diff)
downloadtox-git-057894f95a4979756f1e8dfdfdcc8efc51b0ad6a.tar.gz
update legacy setup.py error message to document isolated_build (#1467)
-rw-r--r--src/tox/package/builder/legacy.py6
1 files changed, 3 insertions, 3 deletions
diff --git a/src/tox/package/builder/legacy.py b/src/tox/package/builder/legacy.py
index 4ddc03b5..935a68ab 100644
--- a/src/tox/package/builder/legacy.py
+++ b/src/tox/package/builder/legacy.py
@@ -14,10 +14,10 @@ def make_sdist(config, session):
" {}\n"
"You can\n"
" 1. Create one:\n"
- " https://packaging.python.org/tutorials/distributing-packages/#setup-py\n"
+ " https://tox.readthedocs.io/en/latest/example/package.html\n"
" 2. Configure tox to avoid running sdist:\n"
- " https://tox.readthedocs.io/en/latest/example/general.html"
- "#avoiding-expensive-sdist".format(setup)
+ " https://tox.readthedocs.io/en/latest/example/general.html\n"
+ " 3. Configure tox to use an isolated_build".format(setup)
)
raise SystemExit(1)
with session.newaction("GLOB", "packaging") as action: