summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorholger krekel <holger@merlinux.eu>2011-07-08 17:15:39 +0200
committerholger krekel <holger@merlinux.eu>2011-07-08 17:15:39 +0200
commitcc9f3d8aa44546dba1b3c5a051a08c086b98f9dd (patch)
tree95404d60fcbb4223ea47d28c9c8b3c68cab26868
parentbf508ef2f19195c8cfdac05539d25d2dc381284e (diff)
downloadtox-git-cc9f3d8aa44546dba1b3c5a051a08c086b98f9dd.tar.gz
update docs and rework them to better fit readthedocs1.1
-rw-r--r--CHANGELOG.txt3
-rw-r--r--doc/_static/sphinxdoc.css2
-rw-r--r--doc/_templates/layout.html22
-rw-r--r--doc/announce/release-1.1.txt50
-rw-r--r--doc/conf.py2
-rw-r--r--doc/index.txt30
-rw-r--r--doc/install.txt7
-rw-r--r--setup.py2
-rw-r--r--tox/__init__.py2
-rw-r--r--toxbootstrap.py2
10 files changed, 59 insertions, 63 deletions
diff --git a/CHANGELOG.txt b/CHANGELOG.txt
index 3bbadaa6..c0ff9273 100644
--- a/CHANGELOG.txt
+++ b/CHANGELOG.txt
@@ -1,4 +1,4 @@
-1.1dev
+1.1
-----------------
- fix issue5 - don't require argparse for python versions that have it
@@ -13,6 +13,7 @@
- inline virtualenv.py (1.6.1) script to avoid a number of issues,
particularly failing to install python3 environents from a python2
virtualenv installation.
+- rework and enhance docs for display on readthedocs.org
1.0
-----------------
diff --git a/doc/_static/sphinxdoc.css b/doc/_static/sphinxdoc.css
index 02b940b0..ab8ab5dc 100644
--- a/doc/_static/sphinxdoc.css
+++ b/doc/_static/sphinxdoc.css
@@ -48,7 +48,7 @@ div.body {
}
div.related {
- font-size: 1em;
+ font-size: 0.8em;
}
div.related ul {
diff --git a/doc/_templates/layout.html b/doc/_templates/layout.html
index 4f54bcfb..1892483a 100644
--- a/doc/_templates/layout.html
+++ b/doc/_templates/layout.html
@@ -1,27 +1,5 @@
{% extends "!layout.html" %}
-{% block relbar1 %}
-{% endblock %}
-{% block relbar2 %}
-{% endblock %}
-
-{% block rootrellink %}
-{% endblock %}
-{% block sidebarrel %}
-{% endblock %}
-
-{% block header %}
-<div style="background-color: white; text-align: left; padding: 10px 10px 15px 15px">
- <h1>tox: virtualenv-based automation of test activities</h1>
- <div style="text-align: left; font-size: 130%; vertical-align: middle;">
- <a href="{{ pathto('index') }}">home</a>&nbsp;|&nbsp;
- <a href="{{ pathto('install') }}">install</a>&nbsp;|&nbsp;
- <a href="{{ pathto('examples') }}">examples</a>&nbsp;|&nbsp;
- <a href="{{ pathto('config') }}">config</a>&nbsp;|&nbsp;
- <a href="{{ pathto('support') }}">support</a>&nbsp;
- </div>
-</div>
-{% endblock %}
{% block footer %}
{{ super() }}
diff --git a/doc/announce/release-1.1.txt b/doc/announce/release-1.1.txt
new file mode 100644
index 00000000..a41c72f6
--- /dev/null
+++ b/doc/announce/release-1.1.txt
@@ -0,0 +1,50 @@
+tox 1.1: the rapid multi-python test automatizer
+===========================================================================
+
+I am happy to announce tox 1.1, a bug fix release easing some commong
+workflows. TOX automates tedious test activities driven from a simple
+``tox.ini`` file, including:
+
+* creation and management of different virtualenv environments with
+ different Python interpreters
+* packaging and installing your package into each of them
+* running your test tool of choice, be it nose, py.test or unittest2 or
+ other tools such as "sphinx" doc checks
+* testing dev packages against each other without needing to upload to PyPI
+
+It works well on virtually all Python interpreters that support virtualenv.
+
+Docs and examples are at:
+
+ http://tox.readthedocs.org
+
+Installation:
+
+ pip install -U tox
+
+Note that code hosting and issue tracking has moved from Google to Bitbucket:
+
+ http://bitbucket.org/hpk42/tox
+
+The 1.0 release includes contributions and is based on feedback and
+work from Chris Rose, Ronny Pfannschmidt, Jannis Leidel, Jakob Kaplan-Moss,
+Sridhar Ratnakumar, Carl Meyer and others. Many thanks!
+
+best,
+Holger Krekel
+
+CHANGES
+---------------------
+
+- fix issue5 - don't require argparse for python versions that have it
+- fix issue6 - recreate virtualenv if installing dependencies failed
+- fix issue3 - fix example on frontpage
+- fix issue2 - warn if a test command does not come from the test
+ environment
+- fixed/enhanced: except for initial install always call "-U
+ --no-deps" for installing the sdist package to ensure that a package
+ gets upgraded even if its version number did not change. (reported on
+ TIP mailing list and IRC)
+- inline virtualenv.py (1.6.1) script to avoid a number of issues,
+ particularly failing to install python3 environents from a python2
+ virtualenv installation.
diff --git a/doc/conf.py b/doc/conf.py
index bc4b67bb..960b50ec 100644
--- a/doc/conf.py
+++ b/doc/conf.py
@@ -132,7 +132,7 @@ html_static_path = ['_static']
#html_use_smartypants = True
# Custom sidebar templates, maps document names to template names.
-html_sidebars = {'index': 'indexsidebar.html'}
+#html_sidebars = {'index': 'indexsidebar.html'}
# Additional templates that should be rendered to pages, maps page names to
# template names.
diff --git a/doc/index.txt b/doc/index.txt
index 30c52b06..6cf4b06c 100644
--- a/doc/index.txt
+++ b/doc/index.txt
@@ -1,10 +1,6 @@
Welcome to the tox automation project
===============================================
-.. note::
-
- Bug reports, feedback, contributions welcome: see :ref:`support`.
-
vision: merge testing and deployment
----------------------------------------
@@ -89,31 +85,6 @@ Current features
.. _pypy: http://pypy.org
-Notes and known limitations
-----------------------------------
-
-* ``tox`` always operates in virtualenv_ environments, it cannot work with
- globally installed Python interpreters because there are no reliable means
- to install and recreate dependencies. Or does it still makes sense to
- allow using global Python installations?
-
-* ``tox`` is fresh on the Python testing scene (first release July 2010) and
- needs some battle testing and feedback. It is is likely to evolve in
- (possibly incompatible) increments as it provides more power to configure
- and customize the test process.
-
-* ``tox`` uses virtualenv_ and virtualenv5_, the latter being a fork
- of virtualenv3_ which roughly works with Python3 but has less features
- (no "pip" and other problems). This comes with limitations and you
- may run into them when trying to create python3 based virtual environments.
- IMO the proper solution is: virtualenv_ needs to merge
- and grow proper native Python3 support, preferably in a "single-source" way.
-
-* ``tox`` currently uses a ``setup.py sdist`` invocation to create
- an installable package and then invokes ``pip`` or ``easy_install`` to
- install into each test environment. There is no support for other
- installation methods.
-
.. _`tox.ini`: :doc:configfile
.. toctree::
@@ -127,6 +98,7 @@ Notes and known limitations
links
announce/release-0.5
announce/release-1.0
+ announce/release-1.1
.. include:: links.txt
diff --git a/doc/install.txt b/doc/install.txt
index 8f67efea..6394920b 100644
--- a/doc/install.txt
+++ b/doc/install.txt
@@ -1,15 +1,10 @@
tox installation
==================================
-.. note::
-
- tox is alpha software and may have crucial platform-specific
- or environment specific bugs. Use with care.
-
Install info in a nutshell
----------------------------------
-**Pythons**: 2.4, 2.5, 2.6, 2.7, 3.0, 3.1.x, Jython-2.5.1, PyPy-trunk
+**Pythons**: CPython 2.4-3.2, Jython-2.5.1, pypy-1.5
**Operating systems**: Linux, Windows, OSX, Unix
diff --git a/setup.py b/setup.py
index b99e6f6e..40f9cda6 100644
--- a/setup.py
+++ b/setup.py
@@ -36,7 +36,7 @@ def main():
description='virtualenv-based automation of test activities',
long_description=long_description,
url='http://codespeak.net/tox',
- version='1.1.dev5',
+ version='1.1',
license='GPLv2 or later',
platforms=['unix', 'linux', 'osx', 'cygwin', 'win32'],
author='holger krekel',
diff --git a/tox/__init__.py b/tox/__init__.py
index 96703bc2..92263a5f 100644
--- a/tox/__init__.py
+++ b/tox/__init__.py
@@ -1,5 +1,5 @@
#
-__version__ = '1.1.dev5'
+__version__ = '1.1'
class exception:
class Error(Exception):
diff --git a/toxbootstrap.py b/toxbootstrap.py
index 188d686a..80d3ed59 100644
--- a/toxbootstrap.py
+++ b/toxbootstrap.py
@@ -58,7 +58,7 @@ ToDo
"""
-__version__ = '1.1.dev5'
+__version__ = '1.1'
import sys
import os