summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorholger krekel <holger@merlinux.eu>2011-07-07 21:52:18 +0200
committerholger krekel <holger@merlinux.eu>2011-07-07 21:52:18 +0200
commitb6bbee4f1c4c45d739c54aa5ab147c0ebcaa187d (patch)
treec1f0b2a08dabc9eec081fbbe05ed90b22b171e63
parent786c429aa9f0f37affb896fb204160ca26f31628 (diff)
downloadtox-git-b6bbee4f1c4c45d739c54aa5ab147c0ebcaa187d.tar.gz
fix issue3 - only require argparse for python versions that don't ship it
-rw-r--r--CHANGELOG.txt3
-rw-r--r--setup.py8
-rw-r--r--tox/__init__.py2
-rw-r--r--toxbootstrap.py2
4 files changed, 10 insertions, 5 deletions
diff --git a/CHANGELOG.txt b/CHANGELOG.txt
index 99f5ec50..58e18ccf 100644
--- a/CHANGELOG.txt
+++ b/CHANGELOG.txt
@@ -1,9 +1,10 @@
1.1dev
-----------------
+- fix issue5 - don't require argparse for python versions that have it
- fix issue6 - recreate virtualenv if installing dependencies failed
- fix issue3 - fix example on frontpage
-- fixed/enhanced: except for initial install always call use "-U
+- fixed/enhanced: except for initial install always call "-U
--no-deps" for installing the sdist package to ensure that a package
gets upgraded even if its version number did not change. (reported on
TIP mailing list and IRC)
diff --git a/setup.py b/setup.py
index baf2e555..5cdd71f6 100644
--- a/setup.py
+++ b/setup.py
@@ -27,19 +27,23 @@ For more information, docs and many examples please checkout the `home page`_:
def main():
+ version = sys.version_info[:2]
+ install_requires = ['py>=1.4.3', ]
+ if version < (2,7) or (3,0) <= version <= (3,1):
+ install_requires += ['argparse']
setup(
name='tox',
description='virtualenv-based automation of test activities',
long_description=long_description,
url='http://codespeak.net/tox',
- version='1.1.dev3',
+ version='1.1.dev4',
license='GPLv2 or later',
platforms=['unix', 'linux', 'osx', 'cygwin', 'win32'],
author='holger krekel',
author_email='holger@merlinux.eu',
packages=['tox', ],
entry_points={'console_scripts': 'tox=tox:cmdline'},
- install_requires=['argparse', 'py>=1.4.0a2', ],
+ install_requires=install_requires,
zip_safe=True,
classifiers=[
'Development Status :: 5 - Production/Stable',
diff --git a/tox/__init__.py b/tox/__init__.py
index 006619b8..3b8f4884 100644
--- a/tox/__init__.py
+++ b/tox/__init__.py
@@ -1,5 +1,5 @@
#
-__version__ = '1.1.dev3'
+__version__ = '1.1.dev4'
class exception:
class Error(Exception):
diff --git a/toxbootstrap.py b/toxbootstrap.py
index 0fd43b13..e5997cde 100644
--- a/toxbootstrap.py
+++ b/toxbootstrap.py
@@ -58,7 +58,7 @@ ToDo
"""
-__version__ = '1.1.dev3'
+__version__ = '1.1.dev4'
import sys
import os