summaryrefslogtreecommitdiff
path: root/tox.ini
diff options
context:
space:
mode:
Diffstat (limited to 'tox.ini')
-rw-r--r--tox.ini11
1 files changed, 10 insertions, 1 deletions
diff --git a/tox.ini b/tox.ini
index 0cf26d7..d8408ac 100644
--- a/tox.ini
+++ b/tox.ini
@@ -16,12 +16,21 @@ deps = -r{toxinidir}/requirements.txt
-r{toxinidir}/test-requirements.txt
commands = {posargs}
+[testenv:py27]
+deps = {[testenv]deps}
+ doc8
+commands = bash -x {toxinidir}/setup-test-env.sh python setup.py testr --slowest --testr-args="{posargs}"
+ doc8 doc/source
+
[testenv:cover]
commands =
bash -x {toxinidir}/setup-test-env.sh python setup.py testr --slowest --coverage --testr-args="{posargs}"
[testenv:docs]
-commands = python setup.py build_sphinx
+deps = {[testenv]deps}
+ doc8
+commands = doc8 doc/source
+ python setup.py build_sphinx
[testenv:pep8]
deps = hacking>=0.9.2,<0.10