summaryrefslogtreecommitdiff
path: root/tox.ini
diff options
context:
space:
mode:
authorJoshua Harlow <harlowja@yahoo-inc.com>2014-09-15 10:37:27 -0700
committerJoshua Harlow <harlowja@yahoo-inc.com>2014-09-16 16:44:41 -0700
commit781fb760a63c0ce84940b5e55e2afd4077ede6b6 (patch)
treef30db254942f8ab2b97ebad19bfc126e998ece27 /tox.ini
parent3981a3a3003b1d7df380f39c9ac1451e716a0c18 (diff)
downloadtooz-781fb760a63c0ce84940b5e55e2afd4077ede6b6.tar.gz
Add doc8 to the py27 test running
To ensure the docs are style checked add in doc8 to the py27 tox environment so that the docs will be checked. This also adjusts the one issue that was found in one of the rst files. Change-Id: Iea38d4ac53d9c5255e0694a840c38b04530890ce
Diffstat (limited to 'tox.ini')
-rw-r--r--tox.ini11
1 files changed, 10 insertions, 1 deletions
diff --git a/tox.ini b/tox.ini
index 0cf26d7..d8408ac 100644
--- a/tox.ini
+++ b/tox.ini
@@ -16,12 +16,21 @@ deps = -r{toxinidir}/requirements.txt
-r{toxinidir}/test-requirements.txt
commands = {posargs}
+[testenv:py27]
+deps = {[testenv]deps}
+ doc8
+commands = bash -x {toxinidir}/setup-test-env.sh python setup.py testr --slowest --testr-args="{posargs}"
+ doc8 doc/source
+
[testenv:cover]
commands =
bash -x {toxinidir}/setup-test-env.sh python setup.py testr --slowest --coverage --testr-args="{posargs}"
[testenv:docs]
-commands = python setup.py build_sphinx
+deps = {[testenv]deps}
+ doc8
+commands = doc8 doc/source
+ python setup.py build_sphinx
[testenv:pep8]
deps = hacking>=0.9.2,<0.10