summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYassine Lamgarchal <yassine.lamgarchal@enovance.com>2014-08-19 14:44:36 +0200
committerYassine Lamgarchal <yassine.lamgarchal@enovance.com>2014-08-19 14:55:40 +0200
commit9c3f75621d97c51062179a843b2941e9240270c4 (patch)
tree2483b7bcff5540933516bdbbfc334e6bced390e6
parentd38fe0301d991300a29ab09175f110356fe47653 (diff)
downloadtooz-9c3f75621d97c51062179a843b2941e9240270c4.tar.gz
Add coverage report
Change-Id: Ia520e5f0e96612fe9d0223a2fba1f49bcaa5070f
-rwxr-xr-xsetup-test-env.sh (renamed from run_tests.sh)3
-rw-r--r--test-requirements.txt1
-rw-r--r--tox.ini7
3 files changed, 8 insertions, 3 deletions
diff --git a/run_tests.sh b/setup-test-env.sh
index 591b782..0e7df80 100755
--- a/run_tests.sh
+++ b/setup-test-env.sh
@@ -51,4 +51,5 @@ fi
memcached &
-python setup.py testr --slowest
+# Yield execution to venv command
+$*
diff --git a/test-requirements.txt b/test-requirements.txt
index ef7251e..b4aab07 100644
--- a/test-requirements.txt
+++ b/test-requirements.txt
@@ -8,3 +8,4 @@ testrepository>=0.0.17
testtools>=0.9.32
testscenarios>=0.4
zake>=0.0.9
+coverage>=3.6
diff --git a/tox.ini b/tox.ini
index 27b97b4..aafe41d 100644
--- a/tox.ini
+++ b/tox.ini
@@ -9,14 +9,17 @@ deps = -r{toxinidir}/requirements.txt
install_command = pip install -U {opts} {packages}
usedevelop = True
commands =
- bash -x {toxinidir}/run_tests.sh {posargs}
-
+ bash -x {toxinidir}/setup-test-env.sh python setup.py testr --slowest --testr-args="{posargs}"
[testenv:venv]
deps = -r{toxinidir}/requirements.txt
-r{toxinidir}/test-requirements.txt
commands = {posargs}
+[testenv:cover]
+commands =
+ bash -x {toxinidir}/setup-test-env.sh python setup.py testr --slowest --coverage --testr-args="{posargs}"
+
[testenv:pep8]
deps = hacking>=0.9.2,<0.10
commands =