summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOpenStack Proposal Bot <openstack-infra@lists.openstack.org>2015-02-05 20:20:17 +0000
committerOpenStack Proposal Bot <openstack-infra@lists.openstack.org>2015-02-05 20:20:17 +0000
commit5b77b967618bab41d0ede93d5684db05aea82fc7 (patch)
treea9e934e823f7958f6914be125cd5d2d0d3210b52
parent5edf2b3db33a42b646fe923580debff6b58a1122 (diff)
downloadtooz-5b77b967618bab41d0ede93d5684db05aea82fc7.tar.gz
Updated from global requirements
Change-Id: Ieac4354608ba0d60b51f782d15c5d94297ae63e7
-rw-r--r--requirements-py3.txt9
-rw-r--r--requirements.txt7
-rw-r--r--setup.py8
-rw-r--r--test-requirements.txt3
4 files changed, 21 insertions, 6 deletions
diff --git a/requirements-py3.txt b/requirements-py3.txt
index 5b14e3c..35cfe9e 100644
--- a/requirements-py3.txt
+++ b/requirements-py3.txt
@@ -1,12 +1,15 @@
+# The order of packages is significant, because pip processes them in the order
+# of appearance. Changing the order has an impact on the overall integration
+# process, which may cause wedges in the gate later.
pbr>=0.6,!=0.7,<1.0
Babel>=1.3
stevedore>=1.1.0
six>=1.7.0
-iso8601
+iso8601>=0.1.9
kazoo>=1.3.1
pymemcache>=1.2
zake>=0.1.6
msgpack-python>=0.4.0
retrying>=1.2.3,!=1.3.0
-oslo.utils>=1.0.0
-redis
+oslo.utils>=1.2.0 # Apache-2.0
+redis>=2.10.0
diff --git a/requirements.txt b/requirements.txt
index 5f7325e..895c8fc 100644
--- a/requirements.txt
+++ b/requirements.txt
@@ -1,3 +1,6 @@
+# The order of packages is significant, because pip processes them in the order
+# of appearance. Changing the order has an impact on the overall integration
+# process, which may cause wedges in the gate later.
pbr>=0.6,!=0.7,<1.0
Babel>=1.3
stevedore>=1.1.0
@@ -5,9 +8,9 @@ six>=1.7.0
iso8601>=0.1.9
kazoo>=1.3.1
pymemcache>=1.2
-zake>=0.1
+zake>=0.1.6 # Apache-2.0
msgpack-python>=0.4.0
retrying>=1.2.3,!=1.3.0
futures>=2.1.6
-oslo.utils>=1.0.0
+oslo.utils>=1.2.0 # Apache-2.0
redis>=2.10.0
diff --git a/setup.py b/setup.py
index 304401d..7363757 100644
--- a/setup.py
+++ b/setup.py
@@ -15,9 +15,15 @@
# limitations under the License.
# THIS FILE IS MANAGED BY THE GLOBAL REQUIREMENTS REPO - DO NOT EDIT
-
import setuptools
+# In python < 2.7.4, a lazy loading of package `pbr` will break
+# setuptools if some other modules registered functions in `atexit`.
+# solution from: http://bugs.python.org/issue15881#msg170215
+try:
+ import multiprocessing # noqa
+except ImportError:
+ pass
setuptools.setup(
setup_requires=['pbr'],
diff --git a/test-requirements.txt b/test-requirements.txt
index 9839287..6c62a75 100644
--- a/test-requirements.txt
+++ b/test-requirements.txt
@@ -1,3 +1,6 @@
+# The order of packages is significant, because pip processes them in the order
+# of appearance. Changing the order has an impact on the overall integration
+# process, which may cause wedges in the gate later.
pep8==1.5.7
pyflakes==0.8.1
flake8==2.2.4