summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJonathan Lange <jml@mumak.net>2016-01-12 17:57:19 +0000
committerJonathan Lange <jml@mumak.net>2016-01-12 17:57:19 +0000
commitbd163121070454cae255f1259f3628000c007c92 (patch)
treee9b5cc73916482e67b96916789e8958986f2a8cf
parent5efcd6b5877864e841bfd1694b104474964234ff (diff)
parent3955df38c2613c9274bb7d6756f2d77d63096b5e (diff)
downloadtesttools-bd163121070454cae255f1259f3628000c007c92.tar.gz
Merge branch 'master' into deferred-matchers
-rw-r--r--NEWS16
-rw-r--r--readthedocs-requirements.txt10
2 files changed, 19 insertions, 7 deletions
diff --git a/NEWS b/NEWS
index 180838c..b4546e3 100644
--- a/NEWS
+++ b/NEWS
@@ -22,7 +22,7 @@ Improvements
* Tests for ``assertRaisesRegexp``. (Julia Varlamova, Jonathan Lange)
* Tests that customize ``skipException`` no longer get tracebacks for skipped
- tests. (Jonathan Lange)
+ tests. (Jonathan Lange, #1518101)
* A failing ``expectThat`` now fails tests run with
``AsynchronousDeferredRunTest``. (Jonathan Lange, #1532452)
@@ -34,6 +34,10 @@ Improvements
* New matchers for testing ``Deferred`` code: ``failed``, ``successful``, and
``NO_RESULT``. (Jonathan Lange, Tristan Seligmann, #1369134)
+* ``TestCase`` objects can now be run twice. All internal state is reset
+ between runs. In particular, testtools tests can now be run with
+ ``trial -u``. (Jonathan Lange, #1517879)
+
Changes
-------
@@ -43,11 +47,6 @@ Changes
* ``addCleanup`` can now only be called within a test run.
(Jonathan Lange)
-* ``TestCase`` objects can now be run twice. All internal state is reset
- between runs. (Jonathan Lange)
-
-* Last release of testtools to support Python 3.2. (Jonathan Lange)
-
* ``TestCase.skip`` deprecated. Use ``skipTest`` instead.
(Jonathan Lange, #988893)
@@ -60,7 +59,10 @@ Changes
* Last release of testtools to support Python 2.6. (Jonathan Lange)
* Report on all duplicate test ids when sorting test suites that contain
- duplicate ids. (Thomas Bechtold, Jonathan Lange)
+ duplicate ids. (Thomas Bechtold, Jonathan Lange, #1390082)
+
+* Add ``readthedocs-requirements.txt`` so readthedocs.org can build the
+ Twisted API documentation. (Jonathan Lange)
1.8.1
~~~~~
diff --git a/readthedocs-requirements.txt b/readthedocs-requirements.txt
new file mode 100644
index 0000000..e44982f
--- /dev/null
+++ b/readthedocs-requirements.txt
@@ -0,0 +1,10 @@
+# Since Twisted is an optional dependency, it doesn't get installed by `python
+# setup.py install`. However, if Twisted is not installed, then the
+# documentation for our Twisted support code won't render on readthedocs.
+#
+# Thus, this requirements.txt is specifically devoted to readthedocs.org, so
+# that it knows exactly what to install in order to render the full
+# documentation.
+
+testtools[test]
+Twisted