summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobert Collins <robertc@robertcollins.net>2013-04-08 22:37:24 +1200
committerRobert Collins <robertc@robertcollins.net>2013-04-08 22:37:24 +1200
commit425d893d8e7f48982c12442f3d374b0a7dc99afe (patch)
tree940cd27e4c17ae6322cda6ed12bac670f37f2601
parent6e5c6d37748ecd8f590348605967c6b26a6da2d9 (diff)
downloadtestrepository-425d893d8e7f48982c12442f3d374b0a7dc99afe.tar.gz
Release 0.0.15, with minimal subunit v2 support.0.0.15
-rw-r--r--NEWS3
-rw-r--r--doc/DEVELOPERS.txt4
-rwxr-xr-xsetup.py2
-rw-r--r--testrepository/__init__.py2
4 files changed, 7 insertions, 4 deletions
diff --git a/NEWS b/NEWS
index df06aaa..3816bb7 100644
--- a/NEWS
+++ b/NEWS
@@ -5,6 +5,9 @@ testrepository release notes
NEXT (In development)
+++++++++++++++++++++
+0.0.15
+++++++
+
CHANGES
-------
diff --git a/doc/DEVELOPERS.txt b/doc/DEVELOPERS.txt
index 1169150..dd86d22 100644
--- a/doc/DEVELOPERS.txt
+++ b/doc/DEVELOPERS.txt
@@ -50,5 +50,5 @@ the environment. This can be very useful for diagnosing problems.
Releasing
---------
-Update testrepository/__init__.py version numbers. Release to pypi. Pivot the
-next milestone on LP to version, and make a new next milestone.
+Update NEWS and testrepository/__init__.py version numbers. Release to pypi.
+Pivot the next milestone on LP to version, and make a new next milestone.
diff --git a/setup.py b/setup.py
index 9582c04..dcf04b6 100755
--- a/setup.py
+++ b/setup.py
@@ -96,7 +96,7 @@ setup(name='testrepository',
install_requires=[
'fixtures',
'python-subunit >= 0.0.10',
- 'testtools >= 0.9.29',
+ 'testtools >= 0.9.30',
],
extras_require = dict(
test=[
diff --git a/testrepository/__init__.py b/testrepository/__init__.py
index d0ace01..011819e 100644
--- a/testrepository/__init__.py
+++ b/testrepository/__init__.py
@@ -33,4 +33,4 @@ The tests package contains tests and test specific support code.
# established at this point, and setup.py will use a version of next-$(revno).
# If the releaselevel is 'final', then the tarball will be major.minor.micro.
# Otherwise it is major.minor.micro~$(revno).
-__version__ = (0, 0, 14, 'final', 0)
+__version__ = (0, 0, 15, 'final', 0)