summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorianb <devnull@localhost>2009-03-15 18:01:48 +0000
committerianb <devnull@localhost>2009-03-15 18:01:48 +0000
commitdec8384da126b9aeefdf23660c0abcbf7f5a343b (patch)
tree7af3359d5e5ceb21404f3c171b149071a4baa8ee
parent99a47ef5e060f0f06d13e5f8cfeb65bbc66b466c (diff)
downloadtempita-dec8384da126b9aeefdf23660c0abcbf7f5a343b.tar.gz
use setup.py test to do the testing
-rw-r--r--setup.cfg4
-rw-r--r--setup.py2
-rwxr-xr-xtest6
3 files changed, 6 insertions, 6 deletions
diff --git a/setup.cfg b/setup.cfg
index a042816..a64c0e1 100644
--- a/setup.cfg
+++ b/setup.cfg
@@ -31,3 +31,7 @@ distribute = register sdist bdist_egg upload pudge publish
[egg_info]
tag_build = dev
tag_svn_revision = true
+
+[nosetests]
+with-doctest = 1
+doctest-extension = txt
diff --git a/setup.py b/setup.py
index 4a9739a..66918c0 100644
--- a/setup.py
+++ b/setup.py
@@ -35,6 +35,8 @@ You can install from the `svn repository
url='http://pythonpaste.org/tempita/',
license='MIT',
packages=['tempita'],
+ tests_require=['nose'],
+ test_suite='nose.collector',
include_package_data=True,
zip_safe=True,
)
diff --git a/test b/test
deleted file mode 100755
index 05a6f89..0000000
--- a/test
+++ /dev/null
@@ -1,6 +0,0 @@
-#!/bin/sh
-NOSE_WITH_DOCTEST=t
-export NOSE_WITH_DOCTEST
-NOSE_DOCTEST_EXTENSION=txt
-export NOSE_DOCTEST_EXTENSION
-nosetests $*