summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorianb <devnull@localhost>2007-07-24 01:09:10 +0000
committerianb <devnull@localhost>2007-07-24 01:09:10 +0000
commitae85a25da6e5e317a44c2e56f3d5ab24835916ce (patch)
tree5c711d947e0ec253aa6937aaafa58e9855478409
parent550480d76ba9a5632e39461cfa81dfd92473d77f (diff)
downloadtempita-ae85a25da6e5e317a44c2e56f3d5ab24835916ce.tar.gz
doc updates
-rw-r--r--docs/index.txt13
-rw-r--r--setup.py8
2 files changed, 20 insertions, 1 deletions
diff --git a/docs/index.txt b/docs/index.txt
index 50d05f5..a2aafc9 100644
--- a/docs/index.txt
+++ b/docs/index.txt
@@ -15,6 +15,10 @@ seek to take over the templating world, or adopt many new features.
I just wanted a small templating language for cases when ``%`` and
``string.Template`` weren't enough.
+Discussion should go the the `Paste-users mailing list
+<http://pythonpaste.org/community/mailing-list.html>`_ and bugs in the
+`Paste Trac instance <http://trac.pythonpaste.org/>`_.
+
Why Another Templating Language
===============================
@@ -346,6 +350,15 @@ pos)`` and ``_exec(code, ns, pos)``, which evaluate and execute
expressions and statements. You could probably make this language
safe with appropriate implementations of those methods.
+Including Tempita In Your Project
+=================================
+
+If you don't want to use Setuptools and have Tempita as a dependency,
+you can add the ``svn:external``
+``http://svn.pythonpaste.org/Tempita/trunk/tempita tempita`` (or link
+to a tag). It's about 730 lines of code (not counting comments and
+whatnot), and 30Kb (60Kb with .pyc files).
+
Still To Do
===========
diff --git a/setup.py b/setup.py
index 078b167..2cfc794 100644
--- a/setup.py
+++ b/setup.py
@@ -7,6 +7,12 @@ setup(name='Tempita',
version=version,
description="A very small text templating language",
long_description="""\
+Tempita is a small templating language for text substitution.
+
+This isn't meant to be the Next Big Thing in templating; it's just a
+handy little templating language for when your project outgrows
+``string.Template`` or ``%`` substitution. It's small, it embeds
+Python in strings, and it doesn't do much else.
""",
classifiers=[
'Development Status :: 4 - Beta',
@@ -17,7 +23,7 @@ setup(name='Tempita',
keywords='templating template language html',
author='Ian Bicking',
author_email='ianb@colorstudy.com',
- url='',
+ url='http://pythonpaste.org/tempita/',
license='MIT',
packages=find_packages(exclude=['ez_setup', 'examples', 'tests']),
include_package_data=True,