summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohannes Dewender <github@JonnyJD.net>2013-11-02 03:35:20 +0100
committerJohannes Dewender <github@JonnyJD.net>2013-11-02 03:35:20 +0100
commite17ad9da6c14b2b7121fd2edf087c8c323b405d5 (patch)
tree5c12e8fb6ce9db8632c1ddd64f5744a53e05955c
parentbfbb996c6d0ed7b5bf6f6e2fe25125877aa8eb5c (diff)
downloadtargetcli-e17ad9da6c14b2b7121fd2edf087c8c323b405d5.tar.gz
debian: remove rc script
This is now in python3-rtslib-fb. Signed-off-by: Johannes Dewender <github@JonnyJD.net>
-rwxr-xr-xdebian/rules3
-rw-r--r--debian/target.init54
-rw-r--r--debian/targetcli-fb.prerm4
3 files changed, 0 insertions, 61 deletions
diff --git a/debian/rules b/debian/rules
index 9347d18..03a168e 100755
--- a/debian/rules
+++ b/debian/rules
@@ -20,9 +20,6 @@ override_dh_auto_build:
override_dh_auto_install:
python$(PYTHON3) setup.py install --root=$(install_dir) --install-layout=deb
-override_dh_installinit:
- dh_installinit --name target
-
override_dh_auto_clean:
dh_auto_clean
rm -rf build
diff --git a/debian/target.init b/debian/target.init
deleted file mode 100644
index 6d9fe3b..0000000
--- a/debian/target.init
+++ /dev/null
@@ -1,54 +0,0 @@
-#!/bin/bash
-
-### BEGIN INIT INFO
-# Provides: target
-# Default-Start: 3 4 5
-# Default-Stop: 0 1 2 6
-# Required-Start: $local_fs $network
-# Required-Stop: $local_fs $network
-# Short-Description: Start LIO targets
-# Description: Loads configfs and restores LIO config with targetcli
-### END INIT INFO
-
-
-case "$1" in
- start)
- if [ ! -d /sys/kernel/config ]; then
- echo "Mounting configfs"
- modprobe configfs
- mount -t configfs configfs /sys/kernel/config
- if [ $? != 0 ]; then
- exit 1
- fi
- fi
- echo "Starting lio targets"
- /usr/bin/targetcli restoreconfig clear_existing=true
- if [[ $? -gt 0 ]]; then
- exit 1
- fi
- ;;
-
- stop)
- echo "Stopping lio targets"
- /usr/bin/targetcli clearconfig confirm=true
- if [[ $? -gt 0 ]]; then
- exit 1
- fi
- ;;
-
- restart|force-reload)
- $0 stop
- sleep 3
- $0 start
- ;;
-
- status)
- echo "Checking status of lio targets";
- /usr/bin/targetcli sessions
- ;;
-
- *)
- echo "usage: $0 {start|stop|restart|force-reload|status}"
-esac
-
-exit 0
diff --git a/debian/targetcli-fb.prerm b/debian/targetcli-fb.prerm
deleted file mode 100644
index 8fe902f..0000000
--- a/debian/targetcli-fb.prerm
+++ /dev/null
@@ -1,4 +0,0 @@
-# manual cleanup
-# debhelpers uses targetcli again to stop the service after cleanup
-# so we have to clean again
-rm -rf /usr/lib/python*/dist-packages/targetcli/*.pyc