summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohannes Dewender <github@JonnyJD.net>2013-10-25 18:07:19 +0200
committerJohannes Dewender <github@JonnyJD.net>2013-10-26 19:33:05 +0200
commit0ca43d5d8c6a74f9074282639ffc08984ebf799c (patch)
tree87d210d345bc0a17a2f5d2ad732e42f7216f7a14
parentc0caf838e0d21301c5ae8d519bcea5659662383f (diff)
downloadtargetcli-0ca43d5d8c6a74f9074282639ffc08984ebf799c.tar.gz
debian: switch to using Python 3
Signed-off-by: Johannes Dewender <github@JonnyJD.net>
-rw-r--r--debian/control9
-rwxr-xr-xdebian/rules13
-rw-r--r--source/format1
3 files changed, 16 insertions, 7 deletions
diff --git a/debian/control b/debian/control
index 1c93204..42226ae 100644
--- a/debian/control
+++ b/debian/control
@@ -2,15 +2,14 @@ Source: targetcli-fb
Section: python
Priority: optional
Maintainer: Andy Grover <andy@groveronline.com>
-Build-Depends: debhelper(>= 8), python (>=2.6.6-3~), python-setuptools, python-configshell-fb, python-rtslib-fb
+Build-Depends: debhelper(>= 8), python3 , python3-setuptools, python3-configshell-fb, python3-rtslib-fb
Standards-Version: 3.9.4
-X-Python-Version: >= 2.6
+X-Python3-Version: >= 3.1
Package: targetcli-fb
Architecture: all
-Depends: ${python:Depends}, ${misc:Depends}, python-configshell-fb, python-rtslib-fb
-Suggests: targetcli-fb-doc
+Depends: python3:any (>= 3.1), ${misc:Depends}, python3-configshell-fb, python3-rtslib-fb
Conflicts: targetcli, targetcli-frozen, lio-utils
Description: CLI shell for the RisingTide Systems target (free branch).
.
- This package contains the targetcli CLI.
+ This package contains the targetcli CLI.
diff --git a/debian/rules b/debian/rules
index ac0a879..9347d18 100755
--- a/debian/rules
+++ b/debian/rules
@@ -1,15 +1,24 @@
#!/usr/bin/make -f
build_dir = build
-install_dir = $(CURDIR)/debian/tmp
+install_dir = $(CURDIR)/debian/targetcli-fb
#export DH_VERBOSE=1
+PYTHON3=$(shell py3versions -vr)
+
+# prevent internet access / don't use PyPi
export http_proxy = http://127.0.0.1:9
%:
- dh $@ --with python2
+ dh $@ --with python3
+
+override_dh_auto_build:
+ python$(PYTHON3) setup.py build
+
+override_dh_auto_install:
+ python$(PYTHON3) setup.py install --root=$(install_dir) --install-layout=deb
override_dh_installinit:
dh_installinit --name target
diff --git a/source/format b/source/format
new file mode 100644
index 0000000..89ae9db
--- /dev/null
+++ b/source/format
@@ -0,0 +1 @@
+3.0 (native)