summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKenneth Reitz <me@kennethreitz.org>2017-08-27 03:26:21 -0400
committerKenneth Reitz <me@kennethreitz.org>2017-08-27 03:26:21 -0400
commita50ff92ff2aaeae5958728cc4363f0ced23ad772 (patch)
tree91756c1c53dae996c29db00b57f2b800e10683d5
parent383d4b9c4e0fc24d5a406cfd3293432821f7901e (diff)
downloadtablib-a50ff92ff2aaeae5958728cc4363f0ced23ad772.tar.gz
only require pandas if python isn't 2.6
Signed-off-by: Kenneth Reitz <me@kennethreitz.org>
-rwxr-xr-xsetup.py7
1 files changed, 5 insertions, 2 deletions
diff --git a/setup.py b/setup.py
index 5691821..ad94b65 100755
--- a/setup.py
+++ b/setup.py
@@ -47,10 +47,13 @@ install = [
'unicodecsv',
'xlrd',
'xlwt',
- 'pyyaml',
- 'pandas',
+ 'pyyaml'
]
+# only require Pandas if Python isn't 2.6.
+if not (sys.version_info[0] == 2 and sys.version_info[1] == 6):
+ install.append('pandas')
+
with open('tablib/core.py', 'r') as fd:
version = re.search(r'^__version__\s*=\s*[\'"]([^\'"]*)[\'"]',
fd.read(), re.MULTILINE).group(1)