summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHugo van Kemenade <hugovk@users.noreply.github.com>2019-10-03 10:32:43 +0300
committerClaude Paroz <claude@2xlibre.net>2019-10-03 09:32:43 +0200
commit923711d99a231ca64857dd0dc24a374c596a6c7b (patch)
tree9955430f254d628865d216f309772861f5d9c5bc
parentaac129db660b676da4b1e66637044a9665ba1b26 (diff)
downloadtablib-923711d99a231ca64857dd0dc24a374c596a6c7b.tar.gz
Add support for Python 3.7 and drop 3.4
-rw-r--r--.travis.yml11
-rw-r--r--docs/intro.rst16
-rwxr-xr-xsetup.py5
-rw-r--r--tox.ini2
4 files changed, 16 insertions, 18 deletions
diff --git a/.travis.yml b/.travis.yml
index 53af531..cd17bd1 100644
--- a/.travis.yml
+++ b/.travis.yml
@@ -1,10 +1,11 @@
language: python
cache: pip
-python:
- - 2.7
- - 3.4
- - 3.5
- - 3.6
+matrix:
+ include:
+ - python: 2.7
+ - python: 3.5
+ - python: 3.6
+ - python: 3.7
install:
- pip install -r requirements.txt
script: python test_tablib.py
diff --git a/docs/intro.rst b/docs/intro.rst
index fabaa17..c1b94d9 100644
--- a/docs/intro.rst
+++ b/docs/intro.rst
@@ -74,17 +74,11 @@ THE SOFTWARE.
Pythons Supported
-----------------
-At this time, the following Python platforms are officially supported:
-
-* cPython 2.7
-* cPython 3.3
-* cPython 3.4
-* cPython 3.5
-* cPython 3.6
-
-Support for other Pythons will be rolled out soon.
-
-
+At this time, the following Python versions are officially supported:
+* CPython 2.7
+* CPython 3.5
+* CPython 3.6
+* CPython 3.7
Now, go :ref:`Install Tablib <install>`.
diff --git a/setup.py b/setup.py
index 9b87c6b..5f2ff9a 100755
--- a/setup.py
+++ b/setup.py
@@ -61,11 +61,14 @@ setup(
'Natural Language :: English',
'License :: OSI Approved :: MIT License',
'Programming Language :: Python',
+ 'Programming Language :: Python :: 2',
'Programming Language :: Python :: 2.7',
- 'Programming Language :: Python :: 3.4',
+ 'Programming Language :: Python :: 3',
'Programming Language :: Python :: 3.5',
'Programming Language :: Python :: 3.6',
+ 'Programming Language :: Python :: 3.7',
],
+ python_requires='>=2.7, !=3.0.*, !=3.1.*, !=3.2.*, !=3.3.*, !=3.4.*',
tests_require=['pytest'],
install_requires=install,
extras_require={
diff --git a/tox.ini b/tox.ini
index bc8ee43..0a954c4 100644
--- a/tox.ini
+++ b/tox.ini
@@ -1,6 +1,6 @@
[tox]
minversion = 2.4
-envlist = py27, py34, py35, py36
+envlist = py27, py35, py36, py37
[testenv]
deps = pytest