summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobert Collins <robertc@robertcollins.net>2014-08-27 12:43:14 +1200
committerRobert Collins <robertc@robertcollins.net>2014-08-27 12:43:14 +1200
commit23142dee1fb17edcb90ed535ddb30057fad38a01 (patch)
tree50dc450ea84adfd3c84e1c54a711159ca252d11b
parent1cbb372ae6fed38992db95f3a728ba751b1f7314 (diff)
downloadsubunit-23142dee1fb17edcb90ed535ddb30057fad38a01.tar.gz
Release 0.0.200.0.20
Also * The python-subunit tarball can now have setup run from the current directory. (Robert Collins, #1361857)
-rw-r--r--NEWS6
-rw-r--r--configure.ac2
-rw-r--r--python/subunit/__init__.py2
-rwxr-xr-xsetup.py4
4 files changed, 11 insertions, 3 deletions
diff --git a/NEWS b/NEWS
index 830981a..a0b598b 100644
--- a/NEWS
+++ b/NEWS
@@ -5,6 +5,9 @@ subunit release notes
NEXT (In development)
---------------------
+0.0.20
+------
+
BUGFIXES
~~~~~~~~
@@ -14,6 +17,9 @@ BUGFIXES
* testscenarios is now a test dependency, not an install dependency.
(Arfrever Frehtes Taifersar Arahesis, #1292757)
+* The python-subunit tarball can now have setup run from the current
+ directory. (Robert Collins, #1361857)
+
0.0.19
------
diff --git a/configure.ac b/configure.ac
index 07c96ac..869ed9b 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1,6 +1,6 @@
m4_define([SUBUNIT_MAJOR_VERSION], [0])
m4_define([SUBUNIT_MINOR_VERSION], [0])
-m4_define([SUBUNIT_MICRO_VERSION], [19])
+m4_define([SUBUNIT_MICRO_VERSION], [20])
m4_define([SUBUNIT_VERSION],
m4_defn([SUBUNIT_MAJOR_VERSION]).m4_defn([SUBUNIT_MINOR_VERSION]).m4_defn([SUBUNIT_MICRO_VERSION]))
AC_PREREQ([2.59])
diff --git a/python/subunit/__init__.py b/python/subunit/__init__.py
index ff952c3..30f7110 100644
--- a/python/subunit/__init__.py
+++ b/python/subunit/__init__.py
@@ -153,7 +153,7 @@ from subunit.v2 import ByteStreamToStreamResult, StreamResultToBytes
# If the releaselevel is 'final', then the tarball will be major.minor.micro.
# Otherwise it is major.minor.micro~$(revno).
-__version__ = (0, 0, 19, 'final', 0)
+__version__ = (0, 0, 20, 'final', 0)
PROGRESS_SET = 0
PROGRESS_CUR = 1
diff --git a/setup.py b/setup.py
index 9176398..42ff760 100755
--- a/setup.py
+++ b/setup.py
@@ -36,7 +36,9 @@ VERSION = (
or "0.0")
-os.chdir(os.path.dirname(__file__))
+relpath = os.path.dirname(__file__)
+if relpath:
+ os.chdir(relpath)
setup(
name='python-subunit',
version=VERSION,