summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobert Collins <robertc@robertcollins.net>2013-04-08 22:27:29 +1200
committerRobert Collins <robertc@robertcollins.net>2013-04-08 22:27:29 +1200
commit73970b4f76ebb31925f0c26df53533703377c013 (patch)
tree8193e0c792c1167f8f41c72f333baf673b778dca
parent766b2856f3a493bd92f57c22eda13d6eb7e04a8a (diff)
downloadsubunit-73970b4f76ebb31925f0c26df53533703377c013.tar.gz
Release 0.0.11, depending on the new testtools StreamResult API.0.0.11
-rw-r--r--INSTALL2
-rw-r--r--Makefile.am2
-rw-r--r--NEWS7
-rw-r--r--configure.ac2
-rwxr-xr-xfilters/subunit-ls2
-rwxr-xr-xfilters/subunit2pyunit2
-rw-r--r--python/subunit/__init__.py2
-rw-r--r--python/subunit/filters.py4
-rwxr-xr-xsetup.py2
9 files changed, 15 insertions, 10 deletions
diff --git a/INSTALL b/INSTALL
index eeea734..51c0e79 100644
--- a/INSTALL
+++ b/INSTALL
@@ -14,7 +14,7 @@ Dependencies
* Python for the filters
* 'testtools' (On Debian and Ubuntu systems the 'python-testtools' package,
the testtools package on pypi, or https://launchpad.net/testtools) for
- the extended test API which permits attachments. Version 0.9.23 or newer is
+ the extended test API which permits attachments. Version 0.9.30 or newer is
required. Of particular note, http://testtools.python-hosting.com/ is not
the testtools you want.
* A C compiler for the C bindings
diff --git a/Makefile.am b/Makefile.am
index dfc3d2f..3169ca7 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -33,6 +33,7 @@ EXTRA_DIST = \
python/subunit/tests/test_subunit_tags.py \
python/subunit/tests/test_tap2subunit.py \
python/subunit/tests/test_test_protocol.py \
+ python/subunit/tests/test_test_protocol2.py \
python/subunit/tests/test_test_results.py \
runtests.py \
setup.py \
@@ -77,6 +78,7 @@ pkgpython_PYTHON = \
python/subunit/iso8601.py \
python/subunit/progress_model.py \
python/subunit/run.py \
+ python/subunit/v2.py \
python/subunit/test_results.py
lib_LTLIBRARIES = libsubunit.la
diff --git a/NEWS b/NEWS
index 90da705..4048c12 100644
--- a/NEWS
+++ b/NEWS
@@ -5,6 +5,9 @@ subunit release notes
NEXT (In development)
---------------------
+0.0.11
+------
+
v2 protocol draft included in this release. The v2 protocol trades off human
readability for a massive improvement in robustness, the ability to represent
concurrent tests in a single stream, cheaper parsing, and that provides
@@ -33,8 +36,8 @@ IMPROVEMENTS
- without this pdb output is not reliably visible when stdout is a pipe
as it usually is. (Robert Collins)
-* v2 protocol draft included in this release.
- (Robert Collins)
+* v2 protocol draft included in this release. (Python implementation only so
+ far). (Robert Collins)
* Two new Python classes -- ``StreamResultToBytes`` and
``ByteStreamToStreamResult`` handle v2 generation and parsing.
diff --git a/configure.ac b/configure.ac
index 8c300ee..c38e080 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1,6 +1,6 @@
m4_define([SUBUNIT_MAJOR_VERSION], [0])
m4_define([SUBUNIT_MINOR_VERSION], [0])
-m4_define([SUBUNIT_MICRO_VERSION], [10])
+m4_define([SUBUNIT_MICRO_VERSION], [11])
m4_define([SUBUNIT_VERSION],
m4_defn([SUBUNIT_MAJOR_VERSION]).m4_defn([SUBUNIT_MINOR_VERSION]).m4_defn([SUBUNIT_MICRO_VERSION]))
AC_PREREQ([2.59])
diff --git a/filters/subunit-ls b/filters/subunit-ls
index 4eb164d..be4b29f 100755
--- a/filters/subunit-ls
+++ b/filters/subunit-ls
@@ -46,7 +46,7 @@ result = TestIdPrintingResult(sys.stdout, options.times, options.exists)
if not options.no_passthrough:
result = StreamResultRouter(result)
cat = CatFiles(sys.stdout)
- result.map(cat, 'test_id', test_id=None)
+ result.add_rule(cat, 'test_id', test_id=None)
summary = StreamSummary()
result = CopyStreamResult([result, summary])
result.startTestRun()
diff --git a/filters/subunit2pyunit b/filters/subunit2pyunit
index 8ffae49..4737d67 100755
--- a/filters/subunit2pyunit
+++ b/filters/subunit2pyunit
@@ -38,7 +38,7 @@ def wrap_result(result):
result = StreamToExtendedDecorator(result)
if not options.no_passthrough:
result = StreamResultRouter(result)
- result.map(CatFiles(sys.stdout), 'test_id', test_id=None)
+ result.add_rule(CatFiles(sys.stdout), 'test_id', test_id=None)
return result
test = DecorateTestCaseResult(test, wrap_result,
before_run=methodcaller('startTestRun'),
diff --git a/python/subunit/__init__.py b/python/subunit/__init__.py
index 7470f92..082da90 100644
--- a/python/subunit/__init__.py
+++ b/python/subunit/__init__.py
@@ -160,7 +160,7 @@ from subunit.v2 import ByteStreamToStreamResult, StreamResultToBytes
# If the releaselevel is 'final', then the tarball will be major.minor.micro.
# Otherwise it is major.minor.micro~$(revno).
-__version__ = (0, 0, 10, 'final', 0)
+__version__ = (0, 0, 11, 'final', 0)
PROGRESS_SET = 0
PROGRESS_CUR = 1
diff --git a/python/subunit/filters.py b/python/subunit/filters.py
index bc9ddef..08ea136 100644
--- a/python/subunit/filters.py
+++ b/python/subunit/filters.py
@@ -82,7 +82,7 @@ def run_tests_from_stream(input_stream, result, passthrough_stream=None,
if passthrough_stream is None:
# Not passing non-test events - split them off to nothing.
router = StreamResultRouter(forward_result)
- router.map(StreamResult(), 'test_id', test_id=None)
+ router.add_rule(StreamResult(), 'test_id', test_id=None)
result = CopyStreamResult([router, result])
else:
# otherwise, copy all events to forward_result
@@ -95,7 +95,7 @@ def run_tests_from_stream(input_stream, result, passthrough_stream=None,
else:
passthrough_result = StreamResultToBytes(passthrough_stream)
result = StreamResultRouter(result)
- result.map(passthrough_result, 'test_id', test_id=None)
+ result.add_rule(passthrough_result, 'test_id', test_id=None)
test = ByteStreamToStreamResult(input_stream,
non_subunit_name='stdout')
else:
diff --git a/setup.py b/setup.py
index 7a5087b..1649b16 100755
--- a/setup.py
+++ b/setup.py
@@ -10,7 +10,7 @@ else:
extra = {
'install_requires': [
'extras',
- 'testtools>=0.9.23',
+ 'testtools>=0.9.30',
]
}