summaryrefslogtreecommitdiff
path: root/perl
diff options
context:
space:
mode:
authorRobert Collins <robertc@robertcollins.net>2009-09-09 20:21:50 +1000
committerRobert Collins <robertc@robertcollins.net>2009-09-09 20:21:50 +1000
commite2c7cda30fe4c02042e034d96e34414c37bd23b7 (patch)
treee2397084ba3567275098970a55d76532723b76aa /perl
parent3b11398f6c6247545d846c2bb607b6ff526ecbc1 (diff)
parent64eb387358b33b59bfe6fd2deedda9ff551e8aff (diff)
downloadsubunit-git-e2c7cda30fe4c02042e034d96e34414c37bd23b7.tar.gz
Get make distcheck working with Jelmers perl-install patch (and some minor trunk issues).
Diffstat (limited to 'perl')
-rwxr-xr-xperl/Makefile.PL6
-rwxr-xr-xperl/Makefile.PL.in12
-rw-r--r--perl/lib/Subunit.pm2
3 files changed, 13 insertions, 7 deletions
diff --git a/perl/Makefile.PL b/perl/Makefile.PL
deleted file mode 100755
index 917dd99..0000000
--- a/perl/Makefile.PL
+++ /dev/null
@@ -1,6 +0,0 @@
-use ExtUtils::MakeMaker;
-WriteMakefile(
- 'NAME' => 'Subunit',
- 'VERSION_FROM' => 'lib/Subunit.pm',
- 'test' => { 'TESTS' => 'tests/*.pl' }
-);
diff --git a/perl/Makefile.PL.in b/perl/Makefile.PL.in
new file mode 100755
index 0000000..226de2b
--- /dev/null
+++ b/perl/Makefile.PL.in
@@ -0,0 +1,12 @@
+use ExtUtils::MakeMaker;
+WriteMakefile(
+ 'NAME' => 'Subunit',
+ 'VERSION' => '@SUBUNIT_VERSION@',
+ 'test' => { 'TESTS' => 'tests/*.pl' },
+ 'PMLIBDIRS' => [ 'perl/lib' ],
+);
+sub MY::postamble {
+<<'EOT';
+check: # test
+EOT
+}
diff --git a/perl/lib/Subunit.pm b/perl/lib/Subunit.pm
index 2ae9444..9f6143c 100644
--- a/perl/lib/Subunit.pm
+++ b/perl/lib/Subunit.pm
@@ -23,7 +23,7 @@ require Exporter;
use vars qw ( $VERSION );
-$VERSION = '0.01';
+$VERSION = '0.0.2';
use strict;