summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTrond Norbye <trond.norbye@sun.com>2009-11-22 11:11:57 +0100
committerTrond Norbye <trond.norbye@sun.com>2009-11-22 11:11:57 +0100
commit5bde43c8c73c43fba14b0e779276e114063fe95e (patch)
tree9b1bac7e932a7b0b804ab6101c25ffd0a6786721
parent30916c9930033ead77349ee1403599fc8bd9ffe2 (diff)
downloadsubunit-git-5bde43c8c73c43fba14b0e779276e114063fe95e.tar.gz
Fix review comments
-rw-r--r--Makefile.am2
-rw-r--r--configure.ac6
2 files changed, 4 insertions, 4 deletions
diff --git a/Makefile.am b/Makefile.am
index a69a5db..6c76c7b 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -93,7 +93,7 @@ check-local: perl/Makefile
$(MAKE) -C perl check
clean-local:
- find . -name "*.pyc" | xargs rm -f
+ find . -type f -name "*.pyc" -exec rm -f {} ';'
rm -f perl/Makefile
# Remove perl dir for VPATH builds.
diff --git a/configure.ac b/configure.ac
index cba7335..75e014a 100644
--- a/configure.ac
+++ b/configure.ac
@@ -25,13 +25,13 @@ AC_PROG_LN_S
AC_PROG_LIBTOOL
AM_PATH_PYTHON
-if test "$GCC" = "yes"
-then
+AS_IF([test "$GCC" = "yes"],
+ [
SUBUNIT_CFLAGS="-Wall -Werror -Wextra -Wstrict-prototypes "
SUBUNIT_CFLAGS="$SUBUNIT_CFLAGS -Wmissing-prototypes -Wwrite-strings "
SUBUNIT_CFLAGS="$SUBUNIT_CFLAGS -Wno-variadic-macros "
SUBUNIT_CXXFLAGS="-Wall -Werror -Wextra -Wwrite-strings -Wno-variadic-macros"
-fi
+ ])
AM_CFLAGS="$SUBUNIT_CFLAGS -I\$(top_srcdir)/c/include"
AM_CXXFLAGS="$SUBUNIT_CXXFLAGS -I\$(top_srcdir)/c/include"