summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile18
1 files changed, 18 insertions, 0 deletions
diff --git a/Makefile b/Makefile
new file mode 100644
index 0000000..868043f
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,18 @@
+# Makefile to simplify some common development tasks.
+# Run 'make help' for a list of commands.
+
+PYTHON=`which python`
+
+default: help
+
+help:
+ @echo "Available commands:"
+ @sed -n '/^[a-zA-Z0-9_.]*:/s/:.*//p' <Makefile | sort
+
+test:
+ $(PYTHON) tests/run_tests.py
+
+clean:
+ $(PYTHON) setup.py clean
+ find . -name '*.pyc' -delete
+ find . -name '*~' -delete \ No newline at end of file