summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIhar Hrachyshka <ihrachys@redhat.com>2014-07-30 13:55:44 +0200
committerIhar Hrachyshka <ihrachys@redhat.com>2014-08-23 21:34:13 +0200
commit30f6aeab91d779545f80a229e94f192d70ac2509 (patch)
treec8e69efe6e7110d49c89711312b66139f3bef0d5
parent93ae21007d0100332a5751fc58f7616ced775ef9 (diff)
downloadsqlalchemy-migrate-30f6aeab91d779545f80a229e94f192d70ac2509.tar.gz
pep8: mark all pep8 checks that currently fail as ignored
Change-Id: Ic1dfb51598b920611acb1a0e437a32c5af90beda
-rw-r--r--tox.ini45
1 files changed, 42 insertions, 3 deletions
diff --git a/tox.ini b/tox.ini
index 7288937..8c11717 100644
--- a/tox.ini
+++ b/tox.ini
@@ -75,12 +75,51 @@ commands =
python setup.py testr --slowest --testr-args='{posargs}'
[flake8]
-# F841 local variable 'json_template' is assigned to but never used
+# E121 continuation line indentation is not a multiple of four
+# E122 continuation line missing indentation or outdented
+# E123 closing bracket does not match indentation of opening bracket's line
+# E124 closing bracket does not match visual indentation
+# E125 continuation line does not distinguish itself from next logical line
+# E126 continuation line over-indented for hanging indent
+# E127 continuation line over-indented for visual indent
+# E128 continuation line under-indented for visual indent
+# E202 whitespace before ')'
+# E203 whitespace before ','
+# E225 missing whitespace around operator
+# E226 missing whitespace around arithmetic operator
+# E228 missing whitespace around modulo operator
+# E231 missing whitespace after ','
+# H234 assertEquals is deprecated, use assertEqual
+# E251 unexpected spaces around keyword / parameter equals
+# E261 at least two spaces before inline comment
+# E272 multiple spaces before keyword
+# E301 expected 1 blank line, found 0
+# E302 expected 2 blank lines, found 1
+# E303 too many blank lines (3)
+# E401 multiple imports on one line
+# E501 line too long (<number-of-chars> > 79 characters)
+# E502 the backslash is redundant between brackets
+# E702 multiple statements on one line (semicolon)
+# E712 comparison to True should be 'if cond is True:' or 'if cond:'
+# F401 '<module>' imported but unused
+# F403 'from migrate.exceptions import *' used; unable to detect undefined names
+# F811 redefinition of unused '<type>' from line <lineno>
+# F821 undefined name '<name>'
+# F841 local variable '<variable>' is assigned to but never used
+# H101 Use TODO(NAME)
# H201 no 'except:' at least use 'except Exception:'
-# H302 import only modules.'bla..' does not import a module
+# H202 assertRaises Exception too broad
+# H233 Python 3.x incompatible use of print operator
+# H301 one import per line
+# H302 import only modules. '<import>' does not import a module
# H306 imports not in alphabetical order
+# H401 docstring should not start with a space
+# H402 one line docstring needs punctuation.
+# H403 multi line docstring end on new line
# H404 multi line docstring should start with a summary
-ignore = F841,H201,H302,H306,H404
+# H501 Do not use locals() for string formatting
+# W391 blank line at end of file
+ignore = E121,E122,E123,E124,E125,E126,E127,E128,E202,E203,E225,E226,E228,E231,E251,E261,E272,E301,E302,E303,E401,E501,E502,E702,E712,F401,F403,F811,F821,F841,H101,H201,H202,H233,H234,H301,H302,H306,H401,H402,H403,H404,H501,W391
show-source = true
builtins = _
exclude=.venv,.git,.tox,dist,doc,*openstack/common*,*lib/python*,*egg,tools,build